Installation

More
5 years 2 months ago #79354 by bairdc3
bairdc3 created the topic: Installation
downloaded version: limesurvey192plus-build120425

Can't get it installed through browser sits and building tables and does nothing.

So I run #php cmd_install.php install

It builds tables in database.

I have debug 1; turned on.

Remove install directory.

Go to admin login enter admin id and password nothing happens

CentOS release 4.9 (Final)
PHP 5.2.17
mysql 4.1.22-standard


any ideas

Nothing in the combined apache logs.

Please Log in to join the conversation.

More
5 years 2 months ago #79389 by Mazi
Mazi replied the topic: Installation
1. Can you check at the DB if all tables were created properly and if a user exists at the user table?

2. Though MySQL 4.1 should be supported by Limesurvey, could you try installing on MySQL 5.x?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 2 months ago #79490 by bairdc3
bairdc3 replied the topic: Installation
Tables are installed and admin user is in the table. I created a different name for the adminuser other than admin, and I see it in the lime_users table that it exists. Here is my tables I will give upgrading a shot.

mysql> show tables;
+
+
| Tables_in_account4_limesurvey |
+
+
| lime_answers |
| lime_assessments |
| lime_conditions |
| lime_defaultvalues |
| lime_expression_errors |
| lime_failed_login_attempts |
| lime_groups |
| lime_labels |
| lime_labelsets |
| lime_participant_attribute |
| lime_participant_attribute_names |
| lime_participant_attribute_names_lang |
| lime_participant_attribute_values |
| lime_participant_shares |
| lime_participants |
| lime_question_attributes |
| lime_questions |
| lime_quota |
| lime_quota_languagesettings |
| lime_quota_members |
| lime_saved_control |
| lime_sessions |
| lime_settings_global |
| lime_survey_links |
| lime_survey_permissions |
| lime_survey_url_parameters |
| lime_surveys |
| lime_surveys_languagesettings |
| lime_templates |
| lime_templates_rights |
| lime_user_groups |
| lime_user_in_groups |
| lime_users |
+
+
33 rows in set (0.00 sec)

Please Log in to join the conversation.

More
5 years 2 months ago #79491 by bairdc3
bairdc3 replied the topic: Installation
Shouldn't debug 1; put some type of output in the apache logs or is it somewhere else?

Please Log in to join the conversation.

More
5 years 2 months ago #79494 by bairdc3
bairdc3 replied the topic: Installation
Installed mysql 5.0.95-community Nothing new. Tried reinstall, GUI did not work had to do cmdline install and left everything stock. Still admin page login does nothing. How to debug? Tried the debug 1;

Please Log in to join the conversation.

More
5 years 2 months ago #79495 by Mazi
Mazi replied the topic: Installation
Setting $debug to 2 should result in errors showing up on top of the screen.

Really hard to debug this one. I have also never heard of this issue, but it seems not many users are using CentOS.
Are there no errors at Apache's error log or the MySQL error log?

If you fail to set this up, maybe www.LimeSurvey Professional (previously LimeService) is an alternative.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 2 months ago #79520 by bairdc3
bairdc3 replied the topic: Installation
There must be more troubleshooting than that I am not ready to throw in the towel, and pay for a service when the application should spit out something in the logs somewhere?

Please Log in to join the conversation.

More
5 years 2 months ago #79532 by bairdc3
bairdc3 replied the topic: Installation
120427 22:33:43 20 Connect host4_dbuser@localhost on
20 Init DB host4_limesurvey
20 Query SHOW TABLES
20 Query select version()
20 Query SET CHARACTER SET 'utf8'
20 Query SET NAMES 'utf8'
20 Query SELECT * FROM `lime_settings_global`
20 Query SELECT * FROM `lime_failed_login_attempts` WHERE ip='xx.xxx.xxx.xx'
20 Quit


Every login attempt hits the database but this is all that it shows.

Please Log in to join the conversation.

More
5 years 2 months ago #79533 by bairdc3
bairdc3 replied the topic: Installation
When I go to initialize the database from the Web interface. I get this

120427 22:58:53 155 Connect host4_dbuser@localhost on
155 Init DB host4_limesurvey
155 Query SHOW TABLES
155 Query select version()
155 Query SET CHARACTER SET 'utf8'
155 Query SET NAMES 'utf8'
155 Query SELECT * FROM `lime_settings_global`
155 Query SELECT stg_value FROM `lime_settings_global` where stg_name='force_ssl' LIMIT 1
155 Query SELECT stg_value FROM `lime_settings_global` where stg_name='showxquestions' LIMIT 1
155 Query SELECT stg_value FROM `lime_settings_global` where stg_name='showgroupinfo' LIMIT 1
155 Query SELECT stg_value FROM `lime_settings_global` where stg_name='showqnumcode' LIMIT 1
155 Quit


So it looks like it starts to do something then halts?

Please Log in to join the conversation.

More
5 years 2 months ago #79551 by Mazi
Mazi replied the topic: Installation
Hard to say where it fails, at least the connection to the DB should work fine.

Please re-upload all files in binary mode. Maybe some files were broken during upload.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 2 months ago #79559 by bairdc3
bairdc3 replied the topic: Installation
Mazi,

Thank you for the input, but I uploaded the tar.gz file, if it was corrupted it probably would not untar Would apache 1.3 cause any issues?

Please Log in to join the conversation.

More
5 years 2 months ago #79562 by Mazi
Mazi replied the topic: Installation
I'm not sure about Apache. I think most use version 2.x, so that old version might cause the problems, but that is hard to say.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"
The following user(s) said Thank You: bairdc3

Please Log in to join the conversation.

More
5 years 1 month ago #81086 by bairdc3
bairdc3 replied the topic: Installation
That was it upgraded to V2 and all went well

Please Log in to join the conversation.

Did you already participate in our customer survey?

Don't miss your chance for great prices.

Please click here to participate:

Start now

Start now!

Just create your account and start using Limesurvey today.

Register now