Check out the LimeSurvey source code on GitHub!

Error getting survey results

More
4 years 10 months ago #79278 by bendweasel
No errors when taking survey but afterwards when selecting "Responses and statistics" I get this error:

The website encountered an error while retrieving http://10.6.5.17/personnel/survey/admin/admin.php?action=browse&sid=88194. It may be down for maintenance or configured incorrectly.

Any help would be very much appreciated!

Jackson

Please Log in to join the conversation.

More
4 years 9 months ago #79415 by Mazi
That error message doesn't help much...

1. Which Limesurvey version do you use?

2. Please switch on debug mode by adding the following line to your config.php file:
$debug = '1';

Are there any additional errors reported on top of the page?

3. Can you reproduce the problem with every survey?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 9 months ago #79476 by bendweasel
I uninstalled and reinstalled with the same error, your questions:

1. 192+

2. debug now set to 1. This is the error I get:
Fatal error: Cannot redeclare GetSessionUserRights() (previously declared in /Library/WebServer/Documents/personnel/survey/limesurvey/admin/sessioncontrol.php:220) in /Library/WebServer/Documents/Personnel/Survey/limesurvey/admin/sessioncontrol.php on line 266

3. It did it with one survey before and 2 this time. All surveys produce the same results

I truly appreciate your assistance!

Jackson

Please Log in to join the conversation.

More
4 years 9 months ago #79479 by Mazi
1. What did you set as $rooturl in config.php

2. Does this installation run on your local server?

3. Which URL do you use to call the admin login screen?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 9 months ago #79481 by bendweasel
$rooturl = "http://{$_SERVER}/personnel/survey/limesurvey";

$rootdir = dirname(__FILE__);

I only have a local server. I have a mac set up as a web server and am copying the files directly on to it.

The path to the program is 10.6.5.17/personnel/survey/limesurvey/
The other path in question would be /library/webserver/documents/personnel...

For login I use http://10.6.5.17/personnel/survey/limesurvey/index.php

Thanks

Please Log in to join the conversation.

More
4 years 9 months ago #79482 by bendweasel
Sorry...

Admin login http://10.6.5.17/personnel/survey/limesurvey/admin/admin.php

Please Log in to join the conversation.

More
4 years 9 months ago #79498 by Mazi
Maybe there are some session issues, at least the error message might indicate that. Have a look at this FAQ which lists several session issues: docs.limesurvey.org/Installation+FAQ&str...tions+for+LimeSurvey

Also check if the folder at session.save_path exists and is writeable.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 9 months ago #79523 by bendweasel
No luck with the FAQ's

I don't have a folder named session.save_path. Where should that go? Or is that a variable in one of the files?

Thanks

Please Log in to join the conversation.

More
4 years 9 months ago #79555 by Mazi
The "session.save_path" folder is defined at the php.ini file of your webserver. The folder defined there has to exist on your server and needs to be writable.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form