Check out the LimeSurvey source code on GitHub!

Upgrade to 1.92 --> Conditions don't work anymore

More
4 years 10 months ago #77935 by prady
Hi to all, I've just updated to 1.92+ Build 120330.
All conditions have been automatically converted to expressions, and seem to be ok on paper, but they just don't work...

Thanks for helping me.

Please Log in to join the conversation.

More
4 years 10 months ago #77942 by prady
I've also noticed that:
  1. Validation expressions work, but the questions don't get highlighted if validation is negative. However I still get the error message via floating window.
  2. Progress bar is missing.
I also tried the basic template, but the problems still show.

Please Log in to join the conversation.

More
4 years 10 months ago #77971 by DenisChenu
Hello,

There are a lot of change on some js file. Maybe with clean your cache all goes right.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
The following user(s) said Thank You: prady

Please Log in to join the conversation.

More
4 years 10 months ago #78009 by prady
Thank you Denis!
Unfortunately yesterday I decided to go back to version 1.91.
But I'll keep in mind your advices if I decide to upgrade in the next future.

Thank you anyway.

Nicola Praderio

Please Log in to join the conversation.

More
4 years 10 months ago #78059 by Mazi
Is it possible that you updated from a quite old version to 1.92 and use a customized template?!?
Because not working conditions and progress bar might indicate that a template wasn't adapted for the latest Limesurvey version.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"
The following user(s) said Thank You: prady

Please Log in to join the conversation.

More
4 years 10 months ago #78070 by prady
Hi Mazi, the updated version was 1.91, and i got the same problems with different tamplates, also the default one.
In the past I followed some instructions i found here in the forum, and made some changes to a javascript (I don't remember which one) to activate the google map question with the hybrid view. That's all.
I'm sorry but I can't provide any further info, because I went back to 1.91.

Please Log in to join the conversation.

More
4 years 10 months ago - 4 years 10 months ago #78071 by ulysse68
I had the same problem, with the default template. All conditions set with the "old" conditions assistant (logical branching feature) were present, but inactive. I removed all conditions and set them back with the same assistant, and now it works. I had to do it quickly on a questionnaire and I don't have a backup, so I can't tell more than that.
Last Edit: 4 years 10 months ago by ulysse68.
The following user(s) said Thank You: prady

Please Log in to join the conversation.

More
4 years 10 months ago #78147 by TMSWhite
prady-

Even though you opted to revert to 1.91+, please open a bug ticket and attach the survey (and custom template, if any) that had trouble in 1.92 (plus describe the problem you were having in sufficient detail that we can replicate it) so we can assess whether there are any lingering bugs in 1.92.

Please Log in to join the conversation.

More
4 years 10 months ago #78162 by prady

TMSWhite wrote: please open a bug ticket and attach the survey (and custom template, if any)


Hi, I've just opened a bug report:
http://bugs.limesurvey.org/view.php?id=5984

Please Log in to join the conversation.

More
4 years 10 months ago #78166 by DenisChenu

prady wrote: Hi, I've just opened a bug report:
http://bugs.limesurvey.org/view.php?id=5984

Fixed :)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
The following user(s) said Thank You: prady

Please Log in to join the conversation.

More
4 years 10 months ago #78189 by prady
Superfast! I'll try it as soon as the new build is relased.
:)

Please Log in to join the conversation.

More
4 years 10 months ago #78226 by DenisChenu
You can just change yourself the file qanda.php ;)

github.com/LimeSurvey/LimeSurvey/commit/...8134206d2ea90b6893f6

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form