LimeSurvey behind Proxy

More
5 years 6 months ago - 5 years 6 months ago #77916 by dreier
dreier created the topic: LimeSurvey behind Proxy
Hello Community,

I have actually planned to get LimeSurvey productive in our company. Actually i am restricted to install LimeSurvey 1.92+ Build 120319 on a machine in a local network. Now i got a configuration of a reverse proxy server which is directing on my local server.
Now the proxy redirects to my server without any problem. I can login (via Webserver login) and get into LimeSurvey. But now i am unable to do anything:
If I try to make something, I get on a new Site which tells me "Reloading screen. Please wait." and I get on this site again and again - it loads - done -loads - done...but never get anywhere else.
If I try to use the normal login, I can't even login, I just get redirected to the login site without any information.
So my question is: Is there anything wrong with our proxy server, or do we have to be patient about any configuration in LimeSurvey to use it behind a proxy?

Regards
dreier
Last Edit: 5 years 6 months ago by dreier.

Please Log in to join the conversation.

More
5 years 6 months ago #77929 by dreier
dreier replied the topic: Aw: LimeSurvey behind Proxy
Update:
After changin the "rooturl" in the config to the proxy-url and deleting the browsercache (which i did for sure just after 1hour testing..) the Admin-Site is working fine!
But there is still a problem left: I cannot answer a survey - I can reach the Welcome-Site but by clicking the next button I get to the survey overview site.

Actually I redirect from https to http - could that be the problem? This configuration was not my idea, it was recommended by the proxy admin.

Regards,
dreier

Please Log in to join the conversation.

More
5 years 6 months ago #77937 by Mazi
Mazi replied the topic: Aw: LimeSurvey behind Proxy
This probably is caused by your weird configuration. Another source of trouble might be the server configuration. If there are too strict security settings, e.g. for the "suhosin" module, this might cause problems as well.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 6 months ago #77940 by dreier
dreier replied the topic: LimeSurvey behind Proxy
Hey,

okay solved it by myself - was my mistake:
Have used the proxy as rooturl via http - after changing to https it worked.

Topic can be closed. Sorry for bothering your time.

Cheers
dreier

Please Log in to join the conversation.

More
4 years 7 months ago #93571 by charleslcso
charleslcso replied the topic: Aw: LimeSurvey behind Proxy
Which config file you are referring to? It is not in conf/config.php nor conf/limesurvey.conf.

I can't specify the URL when I create the survey….

Please tell me.

Please Log in to join the conversation.

More
4 years 7 months ago #93573 by charleslcso
charleslcso replied the topic: Aw: LimeSurvey behind Proxy
I got it.

In config-defaults.php, change $config

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now