Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: logic breaks when importing validation from 1.91 to 1.92

logic breaks when importing validation from 1.91 to 1.92 4 years 4 months ago #77881

  • atiut
  • atiut's Avatar
  • Offline
  • Senior Lime
  • Posts: 76
  • Thank you received: 2
  • Karma: 1
This is probably a bug, but I would like to be sure before i submit to the Bugtracker. I have already submitted 2 tickets and I would rather not spam :).

I imported a survey from 1.91 to 1.92. The original had some questions with settings like the below



They were moved into the new installation, where they do not seem to work. But, much worse, they break the questionnaire logic. Namely, any question that does have a condition will become hidden. Once I remove the max value all is fine within the group.

Two questions:
1. Is this a bug or am I doing something wrong?
2. Is there a bulk way to fix it, like a find/replace in the XML? I am playing around with the logic report right now.
The administrator has disabled public write access.

logic breaks when importing validation from 1.91 to 1.92 4 years 4 months ago #77887

  • TMSWhite
  • TMSWhite's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 758
  • Thank you received: 83
  • Karma: 37
Please open a bug ticket and attach the actual survey and provide enough detail that we can try to reproduce the issue.
The administrator has disabled public write access.

logic breaks when importing validation from 1.91 to 1.92 4 years 4 months ago #77889

  • c_schmitz
  • c_schmitz's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 1008
  • Thank you received: 135
  • Karma: 97
Does it work using a factory template?
Best regards

Carsten Schmitz
LimeSurvey project leader
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.391 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form