Check out the LimeSurvey source code on GitHub!

CSS Changes not Visible?

More
4 years 10 months ago #77469 by acp_tests
I tried adding some things to the bottom of the template.css and they did not affect the appearance. In fact, if I bring up the page and do a page source, I see that it's accessing the CSS file "ACPDefault/template.css" BUT if I put the full path for that file in my browser I see a template.css but it does not have my modifications! I'm obviously doing something wrong. I am making the changes in the template editor and I am saving them. If I log out and log back in and go back to the Templated Editor I see the changes. But when I access the CSS directly from my browser I don't see them.

Is there a delay or something else I'm missing?

Please Log in to join the conversation.

More
4 years 10 months ago #77566 by DenisChenu
Last night, i try some change on a Dev template css.

Modify it, don't see change, look at teplate.css :no change.

Firt, i don't understand , after a minute i look at the link ...

I made my change on ls-dev.myurl and look at ls.myurl .....

:)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
4 years 10 months ago #77571 by acp_tests
I found my problem. Stupid pilot error. :blush:

I needed to do a hard refresh, the CSS had been cached by Firefox. If I do Ctrl-F5 it reloads everything and I see the changes. I thought if a file were newer the browser should grab it again, but maybe it's because it's in a database (is it?)

Anyhoo, I got this working. Sorry for the silly post.

Please Log in to join the conversation.

More
4 years 10 months ago #77583 by DenisChenu
It's because it's a css, same thing for js and png.jpg etc ...

The hard think ( have to do 2 refresh (sometimes more)) : background image.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
4 years 10 months ago #77789 by Mazi
acp_tests: That is a common "problem" when editing CSS files. THese are cached by the browser and you need to either clear the cache or do a complete page reload (CTRL+F5) to force the browser loading the new CSS file instead of taking the cached one.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form