Check out the LimeSurvey source code on GitHub!

Statistics - Answer "Not Displayed" for ALL counts.

4 years 10 months ago #77275 by limeuser
Hi there,

I'm new to limesurvey so hopefully this isn't a silly mistake I have made somewhere but I couldn't find any answers searching the forum.

I recently made a test survey on my web server and made it live, so I could test it on different browsers/computers and so I could see the statistics in their full glory.

Unfortunately when I went to view the stats through the response filters every single results from every single question was marked as "not displayed" - "100.00%" and no graphs were produced from the data.

In the general filters if I choose to view the stats it simply sends the following output:

Number of records in this query: 10
Total records in survey: 10
Percentage of total: 100.00%

That's it, no further detail.

I read in the documentation that the "not displayed" error 'can be because of conditions, or just because the participant left the survey before this page was displayed (or just while this page is displayed, but without clicking the Next button).'

I completed all the surveys entirely so I assume this is a condition error, but I have not explicitly set any conditions, I have just been using the default settings.

Some info:

Limesurvey version: current 1.92+(build120315)

Settings: All default (tried various combinations of question settings too)

Web Host:

Database: Linux Shared Hosting account (no physical files that I can edit but I managed to get limesurvey to find the db and the installation went as expected)

I have seen errors here and there too but they may be irrelevant, for example if I click on the 'Global Settings' button it returns; PHP Error Undefined Variable: updatebuild - /limesurvey/application/views/admin/globalSettings_view.php(82)

Maybe this is a case for a re-installation or possibly some database permission related problems since I don't have full control/rights over the database?

Anyway, any advice is greatly appreciated :laugh:

Please Log in to join the conversation.

4 years 10 months ago #78006 by unibi

This is my first posting here. I have exact the same problem in the global settings page too. That's not a problem of fresh installation, because me installation is brand new fresh installed and nothing has been done with it. I created a bug ticket for this. (I have full access to the database). I tried 2.00a3 Build 120315. The standard 1.92+ build does not even start to install for me (it redirects to the installation and does nothing).

With regards,


Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form