Check out the LimeSurvey source code on GitHub!

Error when sending email invitations

More
4 years 11 months ago - 4 years 11 months ago #75825 by swendell
I get an error when sending email invitations:
SMTP -> ERROR: Failed to connect to server: Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP? (253523852

I have extension=php_opensll.dll in my php.ini file
Attachments:
Last Edit: 4 years 11 months ago by swendell.

Please Log in to join the conversation.

More
4 years 11 months ago - 4 years 11 months ago #75826 by swendell
Ok, I figured it out myself, several issues:
Sending via SMTP using my Google Apps email account:

1. SSL is required. I not only had to enable that in php.ini but also in extension.ini file. I needed to SSH log on to my Linux box as user: root to have the rights to save edits to these files on my Synology Linux DiskStation. The clue to check both locations was found when I ran phpinfo(). You can see the output from phpinfo.php in my original post. This eliminated the SSL error.

2. After I still got the connection time out error without the SSL error. I realized this was because Google uses a port 465 for SSL communication, I was assuming port 25. So I changed the setting in Lime survey. See attachment.

If you are using a Google Apps email account remember your user name is This email address is being protected from spambots. You need JavaScript enabled to view it.. This is explained in the link above.
Attachments:
Last Edit: 4 years 11 months ago by swendell.

Please Log in to join the conversation.

More
4 years 11 months ago #75830 by Mazi
Thanks for your feedback. If you are missing certain information at the manual, feel free to update it. It's a wiki, everybody can and should edit it.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 7 months ago #83639 by doniprinanda
:(
Please, help me. i get same error, this is the error notification.

SMTP -> ERROR: Failed to connect to server: Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP? (5)

How to fix it, I have configured right on global setting, but it doesnt work.

see attachment for my email setting. :)

So Please help me..

Thx you..
Attachments:

Please Log in to join the conversation.

More
4 years 7 months ago #83643 by swendell
Where Limsesurvey is installed you probabley do not have SSL configured
Click showPHPinfo button under global settings, there should be a line like this:

OpenSSL support enabled

Please Log in to join the conversation.

More
4 years 7 months ago #83647 by doniprinanda
Hi swendell,
yeah..i found it, it works after i installed openssl on my windows.

Thx for your help sir.

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form