Check out the LimeSurvey source code on GitHub!

ERROR: session has expired:

More
5 years 2 months ago #69751 by Mazi
I would have guessed that suhosin or mod_security causes these problems but I don't see any hints for this.

In general it's mostly caused by security modules which are configured too strictly to deal with large surveys and lots of POST/SESSION data.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 2 months ago #69769 by jvanbussel
Hello all,

I've just changed: session.save_path = /home/surdatab/sessions in /home/surdatab/php.ini

but the result is an error for the whole LS-installation ..., being:

Warning: session_start() [function.session-start]: open(/home/surdatab/sessions/sess_79761cbfeb8f429a67b9b8cd5fe0ce51, O_RDWR) failed: No such file or directory (2) in /home/surdatab/public_html/ls/admin/sessioncontrol.php on line 36

Warning: Unknown: open(/home/surdatab/sessions/sess_79761cbfeb8f429a67b9b8cd5fe0ce51, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/home/surdatab/sessions) in Unknown on line 0

Please Log in to join the conversation.

More
5 years 2 months ago #69771 by Mazi
I think it is a wrong path setting. I don't know why the previous setting should not work as long as the /TMP folder exists and is writeable.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 2 months ago - 5 years 2 months ago #69781 by Jannet
I too get this error message, but not all the time.

1. I do not have any problems in Firefox
2. In IE, Chrome and Safari (Windows) I do not have a problem if I go directly to the survey (= type the survey address in the address bar)
3. In IE, Chrome and Safari I do get the error message if I go to the survey through the link that I put on my website zinadvies.com/cms/penoscan , the link is under "Ga direct naar de scan"

I am using LS 1.91 build 10030. Have not been able to update to the latest build as the 3-step update thingy doesn't work properly.
Last Edit: 5 years 2 months ago by Jannet.

Please Log in to join the conversation.

More
5 years 2 months ago #69790 by Mazi
Jannet: Please upload a phpinfo file so we can take a look at your server configuration. Just put the following code into a file named phpinfo.php and upload it to your webserver:
< ?php phpinfo(); ? >
(Delete the spaces next to </> when copying the code.)
After uploading please post the link to the file.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 2 months ago #69793 by Jannet

Please Log in to join the conversation.

More
5 years 2 months ago #69801 by DenisChenu

jvanbussel wrote: pen(/home/surdatab/sessions/sess_79761cbfeb8f429a67b9b8cd5fe0ce51, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

Oups, you have to create this directory too.

And maybe assign same user right permission than /home/surdatab/public_html :)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
5 years 2 months ago #69806 by Mazi

Jannet wrote: I too get this error message, but not all the time.

1. I do not have any problems in Firefox
2. In IE, Chrome and Safari (Windows) I do not have a problem if I go directly to the survey (= type the survey address in the address bar)
3. In IE, Chrome and Safari I do get the error message if I go to the survey through the link that I put on my website zinadvies.com/cms/penoscan , the link is under "Ga direct naar de scan"

Since the phpinfo.php looks fine I assume that this might be browser related. Maybe you are using a customized template with invalid HTML which causes problems and Firefox is better at dealing with it?!


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 2 months ago - 5 years 2 months ago #69809 by Jannet
I use the vallendar template.

Just tried thebasic one, but same problem.
Last Edit: 5 years 2 months ago by Jannet. Reason: added comment

Please Log in to join the conversation.

More
5 years 2 months ago #69811 by Jannet
As I only get the problem when I open the survey with the link on my website, would that mean that the bad HTML could be in my website, and not in the survey?

Please Log in to join the conversation.

More
5 years 2 months ago #69813 by Jannet
I checked the HTML of my website, and got a clean bill of health from validator.w3.org/

Please Log in to join the conversation.

More
5 years 2 months ago #69815 by Jannet
And I was able to update to the last build, but still the same problem.

Please Log in to join the conversation.

More
5 years 2 months ago #69825 by DenisChenu
Did you have a session in your website, did the session savepath of the 2 application are the same ?

I don't understand, then i search.

Can you have access to the error log ?

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
5 years 2 months ago #69839 by Jannet
As far as I know, I don't have a session on my website. But I guess it is something like that. Fortunately (?) the strange difference between Firefox and the other browsers is over since I was able to update to build 11378/9. Now I get the session has expired in ALL browsers.

I will check the error log and will check to see if there is a session on my website too.

Please Log in to join the conversation.

More
5 years 2 months ago - 5 years 2 months ago #69844 by DenisChenu
Just another idea ....

Can you post the result of this SQL instruction:
SELECT `stg_value` FROM `lime_settings_global` WHERE `stg_name` LIKE 'SessionName'
(best is to have phpmyadmin or pgmyadmin access)

:)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
Last Edit: 5 years 2 months ago by DenisChenu. Reason: code type=sql

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form