Check out the LimeSurvey source code on GitHub!

Survey submission fails

More
5 years 3 months ago #69426 by andrewmudd
I've installed LimeSurvey and created a test survey of one question. When I click "submit" on the survey, the survey page just loads again and the data is not captured. This happens only on one server -- I've tried it on another server and it works fine. LS appears to be generally unstable on this particular survey. I've verified that PHP has the appropriate extension enabled. Any ideas?

Please Log in to join the conversation.

More
5 years 3 months ago #69431 by DenisChenu
Hello,

You have a problem on your server: task to verify:
docs.limesurvey.org/Installation+FAQ

session_save path, suhosin .... etc ...

:)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
5 years 3 months ago #69509 by Mazi
1. Which Limesurvey version do you use?

2. Is there any error message?

3. Did you set any end URL?

4. Which server do you use?

5. Can you post a link to a sample survey?

6. Please upload a phpinfo file so we can take a look at your server configuration. Just put the following code into a file named phpinfo.php and upload it to your webserver:
< ?php phpinfo(); ? >
(Delete the spaces next to </> when copying the code.)
After uploading please post the link to the file.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 2 months ago #69661 by andrewmudd
1. Version 2.0alpha Build 11268
2. No error message when the user tries to submit the survey; it just reloads the survey page
3. No end URL is currently set
4. Apache/2.0.64 (Red Hat)
5. Sure thing -- it's at this link . Use the token "lsforum".
6. PHP Info is here .

Please Log in to join the conversation.

More
5 years 2 months ago #69667 by Mazi
Version 2.0 alpha is an unstable version which should not be used in production. Please use the latest 1.91 for important surveys!

Regarding the problem, please open a ticket at the Bugtracker and...
  1. Give as much information as possible
  2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.
  3. Provide step-by-step instructions how to reproduce the problem.
  4. If possible/helpful please provide screenshots

Afterwards please post the link to the Bugtracker so we can follow the progress.

Thanks!


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 2 months ago #69668 by Mazi
Another hint: the session.save_path is not set. This setting should point to a folder in the webserver which is writeable.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 2 months ago #69671 by andrewmudd
Ah, I see. The problem is that I'm an idiot. 10-4!

Please Log in to join the conversation.

More
5 years 2 months ago #69688 by Mazi
You're welcome!

If our hints have been helpful and you enjoy limesurvey please consider a donation to the team .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.

:-)


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form