Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: ERROR > Session has expired !

ERROR > Session has expired ! 3 years 9 months ago #78860

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5840
  • Thank you received: 347
  • Karma: 261
Please also check the server's error log for further hints. Sometimes some settings like MAX_POST_VARS or MEMORY_LIMIT cause similar problems.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

ERROR > Session has expired ! 3 years 9 months ago #79623

  • deeringa
  • deeringa's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
Thank you for your prompt responses, and I appologize for the delay in mine. I didn't get notified of the responses for some reason. Perhaps they got sent to junk. Anyway, I tail -f'd a couple of the server's logs while attempting to access a newly created survey, and nothing came up. Specifically the error and access logs. I'm attaching the phpinfo() saved as a .htm page. Please forgive my paranoia, as I have removed anything even resembling identifiable information. I don't think you need IP addresses or usernames to help make a diagnosis. :) I've done some digging, and I can't find the recommended MAX_POST_VARS or MEMORY_LIMIT. I don't see a MAX_POST_VARS, but I do see MAX_INPUT_VARS of 1000, and a MEMORY_LIMIT of 128MB. Obviously, I can up these as necessary. Could you post the recommended values here so I can give that a try? Would anything be showing up in the logs if either of those were the problem? Thank you SO much in advance for your help!

PLEASE NOTE: I didn't see the attached .htm file. So I'm hoping if I change the extension to .txt it will be attached. Please remove the .txt from the end to view the file.
Attachments:
Last Edit: 3 years 9 months ago by deeringa. Reason: I did not see the attached .htm file on my post. Re-trying after renaming to .txt
The administrator has disabled public write access.

ERROR > Session has expired ! 3 years 9 months ago #79822

  • deeringa
  • deeringa's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
Any update on this?
The administrator has disabled public write access.

ERROR > Session has expired ! 3 years 9 months ago #79831

  • deeringa
  • deeringa's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
I am beginning to get a bit desperate. This project is scheduled to go live in a couple days, and I'm still getting this Sessions has expired message for every created survey! I've checked the MAX_POST_VARS and MEMORY_LIMIT. MPV = 1000 and ML = 128M. I found in the documentation that 128M should be perfectly acceptable. I can't find anything for MPV. Please help!!
The administrator has disabled public write access.

ERROR > Session has expired ! 3 years 9 months ago #79834

  • lex
  • lex's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
it helped me to set max_input_vars to 5000
The administrator has disabled public write access.

ERROR > Session has expired ! 3 years 9 months ago #79878

  • deeringa
  • deeringa's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
Thanks, lex. I'll give that a shot.
The administrator has disabled public write access.

ERROR > Session has expired ! 3 years 9 months ago #79880

  • deeringa
  • deeringa's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
Nope. Didn't work. I'm still getting the

ERROR

We are sorry but your session has expired.

Either you have been inactive for too long, you have cookies disabled for your browser, or there were problems with your connection.
The administrator has disabled public write access.

ERROR > Session has expired ! 3 years 9 months ago #79882

  • deeringa
  • deeringa's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
I've found where the error is occurring. In index.php on or about line 310, there's a conditional statement looking to see if _SESSION has been set. Just before I print_r($_SESSION), and it is empty. So I do the following:
if ( empty($_SESSION['s_lang']) ) $_SESSION['s_lang'] = 'en';

And that takes care of it. However, I'd rather not trick it in this manner. Where does the $_SESSION variable get set? I know the link to the survey has a 'lang' variable in the GET string.
Last Edit: 3 years 9 months ago by deeringa.
The administrator has disabled public write access.

ERROR > Session has expired ! 3 years 9 months ago #80117

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5840
  • Thank you received: 347
  • Karma: 261
I think the SESSION get's populated when first calling a survey and e.g. passing the lang parameter.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

ERROR > Session has expired ! 3 years 8 months ago #80346

  • mslavin
  • mslavin's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
I feel I may be encountering the same problems. I'm fairly new to this, so it's quite possible my problem is something considerably more basic.

From my homepage, I link to my survey with the link provided by the admin page: foo.bar/rsvp/index.php?sid=96357&lang=en

If I follow that link, everything goes swimmingly. However, at the end of the survey, I link users back to foo.bar. If they follow the link back to the survey, they complete the first section, and then click "Next," and they're redirected to the index of available surveys.

If they select the survey, they can complete it fine. However, if they follow the link back home and try the survey again, the same redirect to the index happens. Effectively, only one out of two attempts completes the survey while "looping" like this.

Again, I'm a newby. This is a freshly created domain, and I'm hosted my Namecheap. I haven't tinkered much with any setting prior to encountering this problem. I'm running LimeSurvey Version 1.92+ Build 120509, I've tried making the edits to php.ini that have been discussed, but it has had no bearing on the problem.

I'd appreciate any help you all may have. If I'm in way over my head, I won't be offended if you tell me to scram and look for a different tool.

Thanks!
The administrator has disabled public write access.

ERROR > Session has expired ! 3 years 8 months ago #80470

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5840
  • Thank you received: 347
  • Karma: 261
When opening the survey at Limesurvey by clicking the "green tire" icon top left, what is the URL?

You might have to add ...&newtest=Y to the survey URL.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

ERROR > Session has expired ! 3 years 8 months ago #80555

  • mslavin
  • mslavin's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Thanks for the reply, Mazi! I didn't get around to trying it out until now.

The "green gear" links to foo.bar/rsvp/index.php?sid=44955&newtest=Y&lang=en

I updated the link on the homepage to add the ...&newtest=Y, but it still seems to redirect to the index of surveys every second time.
The administrator has disabled public write access.

ERROR > Session has expired ! 3 years 8 months ago #80556

  • mslavin
  • mslavin's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
I decided to see if directing users directly to the index would help, but to no avail; they'd still get kicked to the index every 2nd time they tried to submit answers.

I tried making redundant changes to the config.php file, reflecting the changes I'd made to php.ini, and it seems to have done the trick, to a degree.

If I refer people to the survey index, and they enter the survey from the list, everything runs smoothly. If I go back to sending them directly into the survey, it kicks them to the index every 2nd submission.

I think I'm okay with directing users to the index for now, and I'll keep prodding til I find a way to do otherwise. Now the only task is to figure out why the survey index reverts back to the default template rather than the custom one; but that's so far outside of this topic that I'll make a separate post if I can't crack it on my own.

Thanks for all the guidance, yall.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.224 seconds