Global settings-Security-Force HTTPS <ON>

More
5 years 9 months ago #67247 by ly_ugs
ly_ugs created the topic: Global settings-Security-Force HTTPS <ON>
:(
Global settings-Security-Force HTTPS <ON>
I opened the settings are results page immediately shows "HTTP 403 Forbidden error, the server refuses your browser requests, make sure you have access to."
After that I will never not enter https://localhost/limesurvey/admin/install/index.php.
apache2.2, Mysql, php5.3.1, which I have re-installed too. LimeSurvey also re-download the cover off, but no use.



Attachments:

Please Log in to join the conversation.

More
5 years 9 months ago #67262 by Mazi
Mazi replied the topic: Global settings-Security-Force HTTPS <ON>
Have a look at this setting which should help you out by adding it to your config.php:
/**
* @var $ssl_emergency_override boolean forces SSL off
* if You've turned HTTPS/SSL on in the global settings but your
* server doesn't have HTTPS enabled, the only way to turn it off is
* by changing a value in the database directly. This allows you to
* force HTTPS off while you change the global settings for Force Secure.
*
* false = do nothing;
* true = override $force_ssl=on;
*
* This should always be false except in emergencies where you change
* it to true until you fix the problem.
*/
$ssl_emergency_override = false;


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 9 months ago #67300 by ly_ugs
ly_ugs replied the topic: Global settings-Security-Force HTTPS <ON>
:(
Thank you for your help!!!!:P
I tried to give you data entry, but without success.installation or display HTTP 403.
I am a novice, I request a detailed solution.

Attachments:

Please Log in to join the conversation.

More
5 years 9 months ago #67305 by Mazi
Mazi replied the topic: Global settings-Security-Force HTTPS <ON>
Simply add this line at the end of your config.php file and try to log in at the admin backend again:

$ssl_emergency_override = true;


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
2 years 4 months ago #117788 by bingfang
bingfang replied the topic: Global settings-Security-Force HTTPS <ON>
I run into this trouble to turn on force https without check web server, then survey and admin created becomes not access able.

the file to change is

application/config/config-default.php, look for $config change the setting to true.

Please Log in to join the conversation.

Did you already participate in our customer survey?

Don't miss your chance for great prices.

Please click here to participate:

Start now

Start now!

Just create your account and start using Limesurvey today.

Register now