Check out the LimeSurvey source code on GitHub!

Problem with Token file upload

More
5 years 4 months ago #65059 by Mocean
Hi,

I've recently updated to Version 1.91+ Build 10859, and am having trouble uploading respondent information via the token file upload function. The error is related to file permissions for the tmp. file but i've checked these and changed them to 777 ond 755 and still the function does not work!

Am i missing something?

This is the error in full:

Upload file not found. Check your permissions and path (Serveraddress/html/Survey/tmp/MW_Stafflist.csv) for the upload directory

Is it perhaps that my file name is not limesurvey?

Thanks

Please Log in to join the conversation.

More
5 years 4 months ago #65104 by Mocean
I've checked with godaddy who host it and they assure me all the permissions as set apprpopriately.

I've gone ahead and reinstalled the software as per the instructions and now a further error is occuring when on the templates modify page. This is the error..

Forbidden

You don't have permission to access /limesurvey/tmp/template_temp_110830185831.html on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache Server at www.tcf-survey.com Port 80


Now I've checked this file out and adjust the permissions etc.. but still no change. Any thoughts?

Please Log in to join the conversation.

More
5 years 4 months ago #65105 by holch
well, there is more going on on www.tcf-survey.com . Already when calling the domain there are errors showing up. Something in your configuration seems to be seriously wrong.

Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
5 years 4 months ago #65106 by Mocean
Ok I've fixed that error..

Please Log in to join the conversation.

More
5 years 4 months ago - 5 years 4 months ago #65183 by Mocean
Hi again,

I've rechecked with hosting provider and they reassure me that the server is operating properly.

I have attached a document with the errors I am receiving and also the permissions that I have set to the appropriate folders.

I'm still at a loss as to what to do, if a developer is able to private message me or email contact me as I've set up a developer account on our survey engine and I'll get them the login details to have a look.

This is really urgent now so if someone is able to assist that would be really appreciated.

Thanks
C:\fakepath\Survey errors_settings.pdf
Last Edit: 5 years 4 months ago by Mocean. Reason: file did not upload

Please Log in to join the conversation.

More
5 years 4 months ago #65185 by Mocean
Hi apologies document wouldn't upload
Attachments:

Please Log in to join the conversation.

More
5 years 4 months ago #65186 by holch
Sorry, it is almost impossible to read the first to images. They are just too small. Can't you post the important parts, not the whole screen?

Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
5 years 4 months ago #65187 by Mocean
Here you go...
Attachments:

Please Log in to join the conversation.

More
5 years 4 months ago #65188 by holch
Hmm, my folders have 755. I am not an expert, but the zeros of your 705 look strange to me.

Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
5 years 4 months ago #65206 by stockchris
Maybe it could be related not to folder rights but to individual file rights.

We had an issue with template previews. Files temporarily uploaded to the /tmp folder have rights "600" (read and write for owner). However, as the server needs to read them in order to display them (for the template preview), it could not access them and we got a similar error message. Required rights are "644" so that the server can actually read the files. Our admin recommended correcting this by adding the following line to config.php:
umask(0022);

You might want to try this, even though our problem was different. But maybe the underlying cause is the same...

Please Log in to join the conversation.

More
5 years 4 months ago #65232 by Mocean
Thanks for this, this has fixed the template issue, but we still have problems with uploading tokens and/or exported surveys.

Same error as previous
Error
An error occurred uploading your file. This may be caused by incorrect permissions in your serveraddress/html/Survey/tmp folder.

Please Log in to join the conversation.

More
5 years 4 months ago #65238 by jelo
The upload error message can also be displayed when the actual settings of the import dialog are suppressing an import.
Take the error messages with a grain of salt. File permisson problem is most common, but not with a 100% guess rate.

Try Filter blank email addresses/Filter duplicate records on off.
Add a few dummy tokens and export the token file and try to reimport it.What is the result?

To tackle the issue of permissions you have to know what is the default settings of the software stack you're using (e.g. Apache+PHP) and how you transfer files (FTP-User).

To modify the PHP-Code isn't sustainable for most users since they have to modify the code with every update of LimeSurvey or just back away from updating Limesurvey at all.

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form