Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:
  • Page:
  • 1
  • 2

TOPIC: Disappearing characters?

Disappearing characters? 4 years 11 months ago #64443

  • steverubin
  • steverubin's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Hi - this is a wierd one.

Version 1.91+ Build 10647

I enter a question (spelled correctly) and then it appears in the question selection drop-down with various characters missing. Thought it might have been a first-time entry error that got cached, but tested it thoroughly and it is not.

Seems to like eating "v"s.

Any help please?

Not critical but very annoying!

Thanks,

Steve
Last Edit: 4 years 11 months ago by steverubin.
The administrator has disabled public write access.

Disappearing characters? 4 years 11 months ago #64457

  • atiut
  • atiut's Avatar
  • Offline
  • Senior Lime
  • Posts: 76
  • Thank you received: 2
  • Karma: 1
Weird comment for a weird question: are those real "v"s?

The proiblem you mention can happen in various apps with non-ascii characters. V should be fine though... unless there is something else.
The administrator has disabled public write access.

Disappearing characters? 4 years 11 months ago #64478

  • luisr
  • luisr's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 3
  • Thank you received: 1
  • Karma: 0
Hi,

Same problem here, on 1.91+ 10647, normal 'v' are not rendered on text labels, but if I edit the text, they are there. Happens only on lowercase v, not V, on any text edit box. v are not on rendered html on client.

Regards,
LUIS
The administrator has disabled public write access.

Disappearing characters? 4 years 11 months ago #64479

  • steverubin
  • steverubin's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Thanks Luis - I thought for a while I was going crazy!

Gentlemen this is nothing to do with character encoding schemes, it is a quirky bug.
The administrator has disabled public write access.

Disappearing characters? 4 years 11 months ago #64482

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9281
  • Thank you received: 1324
  • Karma: 384
Hello,

Can you export a lss survey file please.

And maybe:

Please open a ticket at the Bugtracker and...
  1. Give as much information as possible
  2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.
  3. Provide step-by-step instructions how to reproduce the problem.
  4. If possible/helpful please provide screenshots

Afterwards please post the link to the Bugtracker so we can follow the progress.

Thanks!

PS: i trye to reproduce and can't reproduce ???
What is you language ?
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
Last Edit: 4 years 11 months ago by DenisChenu. Reason: PS
The administrator has disabled public write access.

Disappearing characters? 4 years 11 months ago #64485

  • luisr
  • luisr's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 3
  • Thank you received: 1
  • Karma: 0
Ticket registered as 5199.

I'm on spanish lang. Changed UI to english but same happens.

Regards,
LUIS
The administrator has disabled public write access.

Disappearing characters? 4 years 11 months ago #64487

  • luisr
  • luisr's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 3
  • Thank you received: 1
  • Karma: 0
sorry, bug ID 5389
The administrator has disabled public write access.
The following user(s) said Thank You: markbegbie

Disappearing characters? 4 years 11 months ago #64488

  • markbegbie
  • markbegbie's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Same issue here. IT currently trying to roll back to previous release.
The administrator has disabled public write access.

Disappearing characters? 4 years 11 months ago #64495

  • aruether
  • aruether's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Yes, we have the same problem as well using English. Version 1.91+ Build 10647.

Can anyone recommend an earlier release that does not have this problem? We are upgrading from 1.86 and the improvements for 1.91 are great!

- Andrew
The administrator has disabled public write access.

Disappearing characters? 4 years 11 months ago #64499

Thank goodness someone else has stumbled on this and navigated their way though sign-up and confirmation (and subseqently found their way back to the forum) to post this.

Confirming we've been seeing this since installing earlier this week - even in the url for the survey completed url (when displayed in survey overview)

Version 1.91+ Build 10629

I looked for issue 5389 in the bug tracker but can't find it.

Screenshot attached shows the 'v' missing from /survey/ in the url hover tooltip in admin - although it is present in the link to the survey higher in the page. I can give further info if needed.

Dean Marshall
Last Edit: 4 years 11 months ago by DenisChenu. Reason: remove link
The administrator has disabled public write access.

Disappearing characters? 4 years 11 months ago #64500

  • c_schmitz
  • c_schmitz's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 999
  • Thank you received: 135
  • Karma: 97
I think it is a bug with a particular PHP version. I cannot reproduce the issue here on various OSs.

bugs.limesurvey.org/view.php?id=5389

Add your PHP version and see if there is a similarity.
Best regards

Carsten Schmitz
LimeSurvey project leader
The administrator has disabled public write access.

Disappearing characters? 4 years 11 months ago #64501

  • steverubin
  • steverubin's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Hi,

My PHP version is 5.2.17 (Heart Internet hosting)

Thanks for submitting the bug.

Steve
Last Edit: 4 years 11 months ago by steverubin.
The administrator has disabled public write access.

Disappearing characters? 4 years 11 months ago #64502

  • c_schmitz
  • c_schmitz's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 999
  • Thank you received: 135
  • Karma: 97
Ok, try the following:

Open common_functions.php


Go to line 4383 (around there)
and replace this line
$sNicetext = preg_replace('/\v/u', '', $sNicetext);

with
        $sNicetext = preg_replace('/[\x0a\x0b\x0c\x0d\x85\x2028\x2029]/u', '', $sNicetext);

Let me know if that helped.
Best regards

Carsten Schmitz
LimeSurvey project leader
The administrator has disabled public write access.

Disappearing characters? 4 years 11 months ago #64504

  • markbegbie
  • markbegbie's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
We rolled back to Version 1.91+ Build 10315 and do not have the vanishing v problem. It appeared when we upgraded and disappeared when we rolled back (about 10 minutes later!).
aruether wrote:
Yes, we have the same problem as well using English. Version 1.91+ Build 10647.

Can anyone recommend an earlier release that does not have this problem? We are upgrading from 1.86 and the improvements for 1.91 are great!

- Andrew
The administrator has disabled public write access.

Disappearing characters? 4 years 11 months ago #64506

  • aruether
  • aruether's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
$sNicetext = preg_replace('/[\x0a\x0b\x0c\x0d\x85\x2028\x2029]/u', '', $sNicetext);

The proposed fix shows the letter v, but removes spaces in survey names, user name, description, etc.

I added a space between the two single quotes (i.e. change: '' to: ' ') and that seemed to work.
Last Edit: 4 years 11 months ago by aruether. Reason: Updated information.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.512 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form