Welcome, Guest
Username: Password:

TOPIC: Forced <p> tag

Forced <p> tag 4 years 10 months ago #63407

  • waitz
  • waitz's Avatar
  • Offline
  • Gold Lime
  • Posts: 171
  • Thank you received: 1
  • Karma: 3
After I updated to 1.91, the questions gets always wrapped in a <p> tag. If I remove it, and press save, the <p> tags reappear.

This is a bit of a drag in the formatting. Is there a way I can change this?
Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |
The administrator has disabled public write access.

Forced <p> tag 4 years 10 months ago #63408

  • c_schmitz
  • c_schmitz's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 985
  • Thank you received: 133
  • Karma: 97
Yes, by updating to the latest version.
Best regards

Carsten Schmitz
LimeSurvey project leader
The administrator has disabled public write access.

Forced <p> tag 4 years 10 months ago #63409

  • waitz
  • waitz's Avatar
  • Offline
  • Gold Lime
  • Posts: 171
  • Thank you received: 1
  • Karma: 3
;) I just did. Need to check again ;)
Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |
The administrator has disabled public write access.

Forced <p> tag 4 years 10 months ago #63410

  • waitz
  • waitz's Avatar
  • Offline
  • Gold Lime
  • Posts: 171
  • Thank you received: 1
  • Karma: 3
It still reappears...
Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |
The administrator has disabled public write access.

Forced <p> tag 4 years 10 months ago #63411

  • c_schmitz
  • c_schmitz's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 985
  • Thank you received: 133
  • Karma: 97
Have you tried clearing your browser cache?
Best regards

Carsten Schmitz
LimeSurvey project leader
The administrator has disabled public write access.

[SOLVED] Re: Forced <p> tag 4 years 10 months ago #63417

  • waitz
  • waitz's Avatar
  • Offline
  • Gold Lime
  • Posts: 171
  • Thank you received: 1
  • Karma: 3
Oh no... :blush:
The basic mistake....
Thanks, all working well
Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |
Last Edit: 4 years 10 months ago by waitz.
The administrator has disabled public write access.

Forced <p> tag 3 years 3 months ago #92509

  • bandelier
  • bandelier's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
I just upgraded to the latest version, cleared cache & cookies, and am still getting the answers wrapped by a <p> tag - which i cannot find in any of the templates. Help!
The administrator has disabled public write access.

Forced <p> tag 3 years 3 months ago #92512

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 4850
  • Thank you received: 714
  • Karma: 215
Have a look at your question text with the WYSIWYG-Editor switched off (source code). You'll probably find your p tag.

If that doesn't help you would have to send a link for us to have a look at the survey and tell us the template were it occurs. Otherwise it will be difficult to help you.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Forced <p> tag 3 years 3 months ago #92513

  • bandelier
  • bandelier's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Thanks for the quick reply. The <p> tag actually appears in the answer portion, not the question. It seems to be embedded in the {ANSWER} in my question.pstpl file. I have cleared all tags & customized the question portion properly - but cannot seem to find where the answer tag is written in order to remove this tag. Each {ANSWER} starts with the following:

<p class="question answer-item text-item

I can't send a link as it's hosted locally.

Thx!
Last Edit: 3 years 3 months ago by bandelier.
The administrator has disabled public write access.

Forced <p> tag 3 years 3 months ago #92515

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 4850
  • Thank you received: 714
  • Karma: 215
Ok. So not in the question text, but the answer text. Sorry, didn't get that.

But honestly, without any access to the source code and without the name of the template it is really hard to help.

What version of LS do you use?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Forced <p> tag 3 years 3 months ago #92518

  • bandelier
  • bandelier's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 6
  • Karma: 0

File Attachment:

File Name: index.txt
File Size:17 KB

Version 2.00+ Build 130206

I'm modifying the bluengrey template that comes with LS and have attached a txt file with the page's source code.

Screen: Question Page

question.pstpl src:

<li {QUESTION_ESSENTIALS} class="{QUESTION_CLASS}{QUESTION_MAN_CLASS}{QUESTION_INPUT_ERROR_CLASS}">
<label>
<!--
<span class="qnumcode">{QUESTION_NUMBER} {QUESTION_CODE} </span>
//-->
<span class="asterisk">{QUESTION_MANDATORY}</span>{QUESTION_TEXT}
</label>
<!-- <span class="questionhelp">{QUESTION_HELP}</span> //-->
{QUESTION_MAN_MESSAGE}
{QUESTION_VALID_MESSAGE}
{QUESTION_FILE_VALID_MESSAGE}

{ANSWER}
<!--
<div class="survey-question-help">
{QUESTIONHELP}
</div>
//-->
</li>


Thanks again - I really appreciate the help. :)
Last Edit: 3 years 3 months ago by bandelier. Reason: trying different browser to add attachment
The administrator has disabled public write access.

Forced <p> tag 3 years 3 months ago #92520

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 4850
  • Thank you received: 714
  • Karma: 215
Does this happen for all question types or for specific ones?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Forced <p> tag 3 years 3 months ago #92521

  • bandelier
  • bandelier's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Appears to be happening with all question types - I have some short text questions as well as dropdown lists. Both of these have answers wrapped by the <p> tag.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.571 seconds