Check out the LimeSurvey source code on GitHub!

ComfortUpdater problem

More
5 years 8 months ago #62357 by mark01
I host with SiteGround. I tried to upgrade to the latest build using ComfortUpgrader. Everything seemed to work well until I tried entering Limesurvey again. I get the following error report -

Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8_unicode_ci,IMPLICIT) for operation '=': SELECT a.*, surveyls_title, surveyls_description, surveyls_welcometext, surveyls_url FROM `lime_surveys` AS a INNER JOIN `lime_surveys_languagesettings` on (surveyls_survey_id=a.sid and surveyls_language=a.language) order by active DESC, surveyls_title

Any suggestions? I do have the files & database backups.
I use an uploaded template "Clear" - could this be the problem?
Regards
Mark

Please Log in to join the conversation.

More
5 years 8 months ago #62361 by ljarbeau
same thing just happened to me .... :( Subscribing to thread

Please Log in to join the conversation.

More
5 years 7 months ago #62404 by tobyrhodes
Hi Mark

I encountered this a couple of weeks ago.

I have found the problem ... it is to do with the collation of individual fields and some tables of the MySQL database ... these all need setting to utf8_unicode_ci (using PHPMyAdmin)

If you follow this thread www.limesurvey.org/en/forum/installation...pgrade-problem#61781
and this bugs.limesurvey.org/view.php?id=4725 , then you should find the solution.

cheers
Toby

:)

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form