Admin login

More
5 years 9 months ago #62302 by gvangass
When I try to login as admin, the app keeps on redirecting me back to the login screen.

Please Log in to join the conversation.

More
5 years 9 months ago #62315 by gvangass
In the phpinfo(), I can see that the session.save_path was not set. I don't have access to the php.ini file(shared hosting).
Is there maybe a workaround for this ?

Please Log in to join the conversation.

More
5 years 9 months ago #62383 by gvangass
Any update ?

I'm desperate, I would even considering change source code to bypass this problem.

Please Log in to join the conversation.

More
5 years 9 months ago #62386 by greg_d
Hi,

If changes in php.ini are not possible you can try using DB session handler. In order to do so add following line to your config.php:
$sessionhandler = 'db';

Please Log in to join the conversation.

More
5 years 9 months ago #62393 by gvangass
Hi
Does this mean anything to you:
Warning: session_module_name() [function.session-module-name]: A session is active. You cannot change the session module's ini settings at this time in /data01/webs/virtual/l/le/les/lese/lesed/lesedi/www.lesedilm.gov.za/web/survey/classes/adodb/session/adodb-session2.php on line 465

This is what happens when I add that setting to config.

Please Log in to join the conversation.

More
5 years 9 months ago #62461 by xubaoguo
Hi, i have also this problem, do you have solve this problem? tell me ok?

Please Log in to join the conversation.

More
5 years 9 months ago #62464 by gvangass
No answer as yet.
May be some one out there that can help ??

Please Log in to join the conversation.

More
5 years 9 months ago #62467 by greg_d
gvangass, I am not able to reproduce your problem. Could you please, attach results of phpinfo? Maybe it will give us a hint.

Please Log in to join the conversation.

More
5 years 9 months ago - 5 years 9 months ago #62477 by greg_d
It looks like session.auto_start On is a problem - you server starts session every page load while limesurvey doesn't need it, the session is started by the application when necessary.

Try modyfing php.ini or try to add following to .htaccess file:
<IfModule mod_php5.c>
  php_value session.auto_start 0
</IfModule>
Last Edit: 5 years 9 months ago by greg_d.

Please Log in to join the conversation.

More
5 years 9 months ago #62479 by gvangass
Thanks it's working
Note: php_value session.auto_start 1
should read: php_value session.auto_start 0

I've previously tried set this value in the config.php file
ini_set("session.auto_start", "0");
But it did't work ?

Please Log in to join the conversation.