Check out the LimeSurvey source code on GitHub!

CK Editor does not load after upgrade to 1.91

More
5 years 8 months ago #62017 by lachmac
After upgrading to version 1.91 the inline editor (CKEditor?) does not load, and so I have to edit the various text elements, and emails in an external HTML editor.

How can I get back to being able to use the inline editor, again?

Please Log in to join the conversation.

More
5 years 8 months ago - 5 years 8 months ago #62021 by gabriel01
I had this problem but with my French user interface
I solved the problem by modifying the file
admin/scripts/ckeditor.36/plugins/limereplacementfields/lang/fr.js
I replace
CKEDITOR.plugins.setLang ('limereplacementfields', 'en', by
CKEDITOR.plugins.setLang ('limereplacementfields', 'fr',

I hope it helps
Regards

See www.limesurvey.org/fr/forum/french-forum...on?limit=10&start=10
Last Edit: 5 years 8 months ago by gabriel01.
The following user(s) said Thank You: lachmac

Please Log in to join the conversation.

More
5 years 8 months ago #62025 by lachmac
Merci, maybe I am missing a file, I do not seem to have any sw.js file, that would be corresponding to the fr.js.

Thanks for input.

Please Log in to join the conversation.

More
5 years 8 months ago - 5 years 8 months ago #62055 by wrenchpilot
-EDIT-
Another case of a variable being referenced that wasn't properly defined in the config-defaults.php

This has happened the last 3 or 4 times I've updated LimeSurvey. Not cool.

Add the $sCKEditorURL to config-defaults.php to fix.
$sCKEditorURL = "$homeurl/scripts/ckeditor.36"
Last Edit: 5 years 8 months ago by wrenchpilot.
The following user(s) said Thank You: lachmac

Please Log in to join the conversation.

More
5 years 8 months ago #62152 by lachmac
Thanks for the respons. I checked the config-defaults.php and the line you mention was already there. Strange. I really wonder how to solve this, it is a bit of a block.

Please Log in to join the conversation.

More
5 years 8 months ago #62153 by lachmac
PROBLEM SOLVED - the "s" was missing from $sCK.....Now it works!

Great thanks to all!

Please Log in to join the conversation.

More
5 years 7 months ago - 5 years 7 months ago #62569 by rocknrole
CKEditor does not load in Chrome!
Did anybody do a Cross Browsertest before releasing this version with a new Editor?
Why switching from FCK when it does not work in all Browsers - thats frustrating - each new release has new problems and we read the announcements "hopefully it is stable".
My question - if you are not sure it is stable - why do you release it?
It seems like each build gets at least a RC....
I am not happy with that.

UPDATE:
The whole jquer UI seems to have a problem in Chrome. The Tabs do not render and I get the followig errors:

Uncaught Range Error: Maximum call stack size exceeded

and

Uncaught Type Error: Cannot read property "regional" of undefined (admin_core.js:12)
Last Edit: 5 years 7 months ago by rocknrole.

Please Log in to join the conversation.

More
5 years 7 months ago #62571 by c_schmitz
rocknrole,

CKEditor loads just fine here in the latest version of Chrome. Maybe you need just to clear your browser cache once in Chrome.

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

More
5 years 7 months ago #62575 by rocknrole
Sorry for this - indeed after clearing the cache, it worked......
thx

Please Log in to join the conversation.

More
5 years 6 days ago - 5 years 6 days ago #74373 by simulator
this may also be caused by apache2 .htaccess setting.

We had a .htaccess restriction for the /admin/ area which is above the
/admin/scripts/ckeditor.36/.htaccess file.

the latter one calls AddType
AddType application/x-javascript .js
AddType text/css .css
AddType text/xml .xml
But according to apache2 doc you need
AllowOverride FileInfo to allow AddType in a .htaccess file.

As AllowOverride can only have 1 argument I used "AllowOverride All", so I solved the problem, by replycing the
AllowOverride AuthConfig
with
AllowOverride All
in my apache or vhost.conf, which looks like this
...
       DocumentRoot /var/www/limesurvey/latest
       <Directory /var/www/limesurvey/latest>
                Options -Indexes +FollowSymLinks -MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
                DirectoryIndex index.php index.html index.htm
        </Directory>
...

/ SIMULATOR / WIEN /
Last Edit: 5 years 6 days ago by simulator. Reason: fehler

Please Log in to join the conversation.

More
5 years 6 days ago #74375 by Mazi
Thanks for your feedback!


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 6 days ago #74416 by DenisChenu
A lot of web server have already:
text/css					css
application/javascript				js
application/xml					xml xsl xsd
in /etc/mime.types

Debian have ot for example, think is too ? No ?

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form