Check out the LimeSurvey source code on GitHub!

delete 'install' directory post install, errors

More
5 years 8 months ago - 5 years 8 months ago #61679 by hossein_au
I just went through the install with the following version numbers:

$versionnumber = "1.91";
$dbversionnumber = 145;
$buildnumber = '10120';

Server running stock standard OpenSuSE 11.3 (64bit): apache 2.2.15, PHP 5.3.3, PostgreSQL 8.4.7. config.php is edited to use potgresql.

Went through the admin page and created and populated the database. After that I got the following message:

<begin>
Congratulations

Your installation is now complete. The final step is to remove or rename the LimeSurvey installation directory (admin/install) on your server since it may be a security risk.

Once this directory has been removed or renamed you will be able to log in to your new LimeSurvey Installation.

Try again
<end>

No matter what I do, I cannot get past this page, I have chmod 000 the install directory, I have renamed it, I have move it outside the entire limesurvey directory, and I have delete it altogether, but all to no avail... I keep getting the above page.

I even searched the limesurvey directory, and the error message seems to come from common.php where the existence of the install directory is checked (as well as the debug level). I have commented out the entire "if" statement, but I keep getting the same page!!! This is really strange...

What am I supposed to do to get past this?
Last Edit: 5 years 8 months ago by hossein_au. Reason: added server information

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form