Check out the LimeSurvey source code on GitHub!

postgresql query problem

More
5 years 9 months ago #61149 by zenek_kraweznik0
I can't sing in to limesurvey. LS refuses all access.

In resetadminpw.php script i have output like that:

SQL command failed: UPDATE users set \"password\"='[password hash]' where uid=1 Reason: ERROR: syntax error at or near "\" LINE 1: UPDATE users set \"password\"='[password hash fragment]... ^

The problem is in 'set \"password\"', it shoud be 'set password'. \" are bad here.

When I remove \" from this query new password is written to the database, but I still cannot sing in.

I tried to insert sha256 hash of password directly into database via psql client, but contet of users table is the same (password hash in db us correct)

I'm using php5.3 and postgreSQL 9.0 (i tested also php5.2 and postgresql 8.3 and 8.4).

Could anyone help me solve this problem?

Please Log in to join the conversation.

More
5 years 8 months ago #61199 by zenek_kraweznik0
I've found new symptom:

In database I have tables like 'users', but adodb want to update 'prefix_users'.

In my config file my $dbprefix is set to '';

Any idea how to solve that?

Please Log in to join the conversation.

More
5 years 8 months ago #61216 by zenek_kraweznik0
Oh, and now I've tables with prefix_users in my mysql database.

Bug in php53? Adodb? I think this is incompatibility between limesurvery and php5.3

Please Log in to join the conversation.

More
5 years 8 months ago #61236 by zenek_kraweznik0
prefix_ in table name is not a problem, that was my mistake.

LimeSurvey is not compatible with PostgreSQL 9

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form