Check out the LimeSurvey source code on GitHub!

Got my first survey done, but after activating it doesn´t work anymore

More
5 years 9 months ago #60722 by Ernst
Hi,

Got my first survey done after the turn and not get anywhere.
When I click on the survey is the following error message and I have no idea why, when most everything was perfect!


ERROR
We are sorry but your session has expired.
Either you have been inactive for too long, you have disabled cookies or there was a problem with your connection.

You can watch it directly under umfrage.coopshops.net/index.php?sid=9553...oken=u3aq29pz9grx3cr

Once you press Next then there comes the error

It really kills my last hairs ;-), because I've already sent out survey to our members and now see all the error screen only.

Hope someone of you here has an idea.

LimeSurvey 1.91+
PHP Version 5.2.11
MySQL 5.0.67
Browser egal

phpini umfrage.coopshops.net/admin/admin.php?action=showphpinfo

Thanks,
Ernst

Please Log in to join the conversation.

More
5 years 9 months ago #60725 by holch
The phpinfo is not shown via that link. You seem to have more problems with your installation. On top of your last link I can find this:
Notice: Undefined index: USER_RIGHT_CONFIGURATOR in /home/www/umfrage_coopshops_net/admin/admin.php on line 679

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: Ernst

Please Log in to join the conversation.

More
5 years 9 months ago #60726 by Ernst
Hi Holch - no I am in the process of reinstalling because it´s cracking my head - its a pitty that it didn´t work

I will retry when i am finished

Please Log in to join the conversation.

More
5 years 9 months ago #60728 by Ernst
I will reinstall it on a different sub

But please look in the link now - i uped the install dir which caused the message you did see.

You will now be able to reproduce my error - the tmp directory is 777

Cheers,
Ernst

Please Log in to join the conversation.

More
5 years 9 months ago #60729 by Ernst
Hi Holch,

I have reinstalled it and I get the same error again

umfrage.coopshops.net/limesurvey/index.p...oken=xky3uukvqct7wwy

I have used the following Pack for install limesurvey191plus-build10060-20110510
I have seen that there was also an error message regarding one \ in line 2914 in the index file

Cheers,
Ernst

Please Log in to join the conversation.

More
5 years 9 months ago #60733 by holch
Please check with a stable version. 1.91 is not yet released as stable.

Your reinstall was on another machine? where is the machine located? Behind a firewall?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
5 years 9 months ago #60734 by Ernst
I had downloaded it from sourceforge where it was declared as stable

Looking for the latest version? Download limesurvey191plus-build10060-20110510.zip (26.8 MB)
Home / 1._LimeSurvey_stable / 1.91+

What is the "latest" official stable?

My server is in a serverfarm in germany

Please Log in to join the conversation.

More
5 years 9 months ago #60735 by holch
Hi!

Well, then either there is something wrong on SF or they didn't publish the information that 1.91 is stable yet. Because as far as I know (and according to the news on limesurvey.org), we are at RC6 for 1.91. It should be fairly stable by now, but it is not officially released.

Checked on SF and you are right. Since 10/05/2011 1.91 seems to be stable. Very strange that there was no news about this on the Limesurvey frontpage. Or did I just overlook it.

To me this sounds very much like a server configuration problem. However, I am not an expert in this area and we might have to wait for other users to jump in (e.g. Carsten Schmitz, Mazi or Lemeur).

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
5 years 9 months ago #60736 by Ernst
I did got it running with 1.90 straight from install - it seems to be an error with the version 1.91+ also there was this error in the index.php with the line 2914 where the \ was missing >>moveprev'; $('#limesurvey').submit();" value=' << "

So i think the release was not checked well before putting it on the web

Cheers,
Ernst

Please Log in to join the conversation.

More
5 years 9 months ago #60737 by holch
Ernst, could you make a bug report? I think this is the fastest way to get this solved. I will try to install 1.91 over the weekend and see if it happens to me as well.

I just saw some others with troubles after the upgrade as well. Not sure what is going wrong, but a bug report (or several) will alert the developers.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
5 years 9 months ago - 5 years 9 months ago #60756 by sp00ky
There is new build 10062. Maye this will do the trick :huh:
It helped me. With 10060 I couldn't even display surveys
Last Edit: 5 years 9 months ago by sp00ky.

Please Log in to join the conversation.

More
5 years 9 months ago - 5 years 9 months ago #60825 by Ernst
Hi sp00ky,

I have tried it. Also the 10062 version brings me to the same error

FEHLER
Es tut uns leid, aber Ihre Sitzung ist abgelaufen.
Entweder sind Sie zu lange inaktiv gewesen, Sie haben Cookies deaktiviert oder es gab ein Problem mit Ihrer Verbindung.
Bitte kontaktieren Sie ... für weitere Unterstützung.

Which means in english inactive or cookie deactivated - both are untrue. And it is the same error as with 10060

On the main level I have the version 1.90+ now running without any problems

Cheers,
Ernst
Last Edit: 5 years 9 months ago by Ernst. Reason: had a misspelling

Please Log in to join the conversation.

More
5 years 9 months ago #60904 by onlyrich
I am having the same issues with mine. I get "We are sorry but your session has expired" after I click next. This happened right after I activated the survey.

Any solution?

Please Log in to join the conversation.

More
5 years 9 months ago #60905 by onlyrich
Hey people,

I did some digging. The error message is in the index.php file, and is under an area which is trying to do something with the language. Can anyone understand this code piece that I'm cutting and pasting?? Do you see what's going on in here? Help?




if (!isset($_SESSION) && (isset($move)) )
// geez ... a session time out! RUN!
{
if (isset($_REQUEST))
{
safe_die('You cannot start this script directly');
}
require_once(dirname(__FILE__).'/classes/core/language.php');
$baselang = GetBaseLanguageFromSurveyID($surveyid);
$clang = new limesurvey_lang($baselang);
//A nice exit
sendcacheheaders();
doHeader();

echo templatereplace(file_get_contents("$standardtemplaterootdir/default/startpage.pstpl"));
echo "<center><br />\n"
."\t<font color='RED'><strong>".$clang->gT("ERROR")."</strong></font><br />\n"
."\t".$clang->gT("We are sorry but your session has expired.")."<br />".$clang->gT("Either you have been inactive for too long, you have cookies disabled for your browser, or there were problems with your connection.")."<br />\n"
."\t".sprintf($clang->gT("Please contact %s ( %s ) for further assistance."),$siteadminname,$siteadminemail)."\n"
."</center><br />\n";

echo templatereplace(file_get_contents("$standardtemplaterootdir/default/endpage.pstpl"));
doFooter();
exit;
};

Please Log in to join the conversation.

More
5 years 9 months ago #60908 by onlyrich
Hey people,

I did some digging. The error message is in the index.php file, and is under an area which is trying to do something with the language. Can anyone understand this code piece that I'm cutting and pasting?? Do you see what's going on in here? Help?




if (!isset($_SESSION) && (isset($move)) )
// geez ... a session time out! RUN!
{
if (isset($_REQUEST))
{
safe_die('You cannot start this script directly');
}
require_once(dirname(__FILE__).'/classes/core/language.php');
$baselang = GetBaseLanguageFromSurveyID($surveyid);
$clang = new limesurvey_lang($baselang);
//A nice exit
sendcacheheaders();
doHeader();

echo templatereplace(file_get_contents("$standardtemplaterootdir/default/startpage.pstpl"));
echo "<center><br />\n"
."\t<font color='RED'><strong>".$clang->gT("ERROR")."</strong></font><br />\n"
."\t".$clang->gT("We are sorry but your session has expired.")."<br />".$clang->gT("Either you have been inactive for too long, you have cookies disabled for your browser, or there were problems with your connection.")."<br />\n"
."\t".sprintf($clang->gT("Please contact %s ( %s ) for further assistance."),$siteadminname,$siteadminemail)."\n"
."</center><br />\n";

echo templatereplace(file_get_contents("$standardtemplaterootdir/default/endpage.pstpl"));
doFooter();
exit;
};

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form