Adding a user fails

More
6 years 5 months ago #58531 by craigwg
craigwg created the topic: Adding a user fails
I am using Version 1.87+ Build 8472.

I have my admin LimeSurvey account which works great. I need to a second account. Whenever I do LimeSurvey returns an error message saying, "
The user name already exists." I assure you it does not. I've looked in the database, verified that there is only one user there.

I also tried adding a user on a different install of LimeSurvey expecting success there, but failed with the same error message.

Is there something I need to do to allow it to accept a new user?

Sub question is, once I add the user I need to give that user only access to one survey. I think that will be down hill, but right now I'd be happy if I could just create a user!

Thanks
Craig

Please Log in to join the conversation.

More
4 years 9 months ago #88574 by Vinay01
Vinay01 replied the topic: Adding a user fails
I am facing the exact same issue.
I am using version limesurvey 2.00+ build121117

Even a backend MySQL insert gives an error, not sure where the problem is?

Please Log in to join the conversation.

More
4 years 9 months ago #88585 by cb75ter
cb75ter replied the topic: Adding a user fails
Hello,

I have the same issue.

I just installed a fresh limesurvey200plus-build121117 and any attempt to create a user will give a "user alrdeady exists" whatever the user name is.

Any Idea ?

Please Log in to join the conversation.

More
4 years 9 months ago - 4 years 9 months ago #88591 by mdekker
mdekker replied the topic: Adding a user fails
Please file a bugreport in our Bugtracker .

---
Menno Dekker
Last Edit: 4 years 9 months ago by mdekker.
The following user(s) said Thank You: cb75ter, cogno

Please Log in to join the conversation.

More
4 years 9 months ago #88622 by cogno
cogno replied the topic: Adding a user fails
I've also had the same problem and am glad to see there's action on this bug so quickly. Since the fix is being commited to v2.1, what's the timeline for the release of that version?

Or, is this something that we can patch ourselves in 2.0?

Please Log in to join the conversation.

More
4 years 9 months ago #88625 by mdekker
mdekker replied the topic: Adding a user fails
Fix is also on 2.00 so it will be released soon. The patch is really simple so if you need it you can patch your own system. Check the linked diffs on the bug bugs.limesurvey.org/view.php?id=6896 there is one for master(=2.00) and one for 2.1
As there is one user that reports that it does not fix all errors, any feedback is welcome.

---
Menno Dekker
The following user(s) said Thank You: cogno

Please Log in to join the conversation.

More
4 years 9 months ago #88628 by cogno
cogno replied the topic: Adding a user fails
Thank you! I've not seen the error in question, myself, and the patch works perfectly for m so far. :)

Please Log in to join the conversation.

Did you already participate in our customer survey?

Don't miss your chance for great prices.

Please click here to participate:

Start now

Start now!

Just create your account and start using Limesurvey today.

Register now