Check out the LimeSurvey source code on GitHub!

Session Lifetime

More
6 years 2 weeks ago #56820 by godber
Hello,
Which php.ini setting effect the Session Lifetime settings? I have Limesurvey 1.9 and the Session Lifetime in the application doesn't appear to effect the timeout time. I think the timeout time is somewhere between 30 min and 3 hours.

I checked the session cookies, and they are set to last until the browser is closed and I can see the sessions file placed in the /var/lib/php5 (on ubuntu). I have tried changing a few things in php.ini but none of them had an effect on the cookies and I don't see where else that timeout is located. Unless I overlooked it in the session file somewhere.

Can anyone else suggest something to try? I was testing this by setting the time out to 60 and 300 seconds and neither of those worked. Ultimately I hope to make it last 60 minutes because I have some fairly long surveys, 30min+, that are timing out.

Austin

Please Log in to join the conversation.

More
6 years 1 week ago #56835 by Mazi
This might be a stupid question, but did you restart the webserver after having made changes to php.ini?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 1 week ago #56924 by godber
Hello Mazi,
It's not a stupid question because that could explain the problem. So thanks for suggesting it. However, I have been restarting apache and clearing my cookies every time I make settings changes.

Austin

Please Log in to join the conversation.

More
6 years 1 week ago #56927 by Mazi
Did you check if the folder set for "session.save_path" exists and is writeable?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 1 week ago #56936 by godber
On my platform, Ubuntu, this appears to be /var/lib/php5 by default and is not set anywhere that I can see. This is definitely writable and I can see the corresponding session information get written into the directory when sessions are created.

Do you know how that session expiration is supposed to work? I can see that the cookies being created are reported to expire when the browser closes. That never changes.

Austin

Please Log in to join the conversation.

More
6 years 1 week ago #56937 by godber
Do those session files contain information on the expiration time?

Please Log in to join the conversation.

More
6 years 1 week ago #56944 by Mazi
I'll try to get in touch with one of the core developers who might answer these questions.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 5 months ago #65768 by doloresev
I think that it exists a configuration file named "config-defaults.php". This file contains a parameter, named "$sessionlifetime", that contains the lifetime of the session in seconds.

Please Log in to join the conversation.

More
5 years 5 months ago #65810 by Mazi

doloresev wrote: I think that it exists a configuration file named "config-defaults.php". This file contains a parameter, named "$sessionlifetime", that contains the lifetime of the session in seconds.

That is correct. Keep in mind that in later version this setting was moved to the "general settings" which you can change at the admin backend. This overrides any setting in config-defaults.php.
Furthermore, depending on the webserver configuration, the server might override any setting done by an application for security reasons.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 5 months ago #65819 by doloresev
Thank you for your answer.

Yesterday I changed the parameter "$sessionlifetime" from the admin backend, but it didn't works ok.

Maybe the error is that I did not restart Apache?

Today we have changed a parameter of php.ini (session.gc_maxlifetime), and later we have restarted Apache, and now it works ok.

Please Log in to join the conversation.

More
5 years 5 months ago #65836 by Mazi

doloresev wrote: Yesterday I changed the parameter "$sessionlifetime" from the admin backend, but it didn't works ok.

Maybe the error is that I did not restart Apache?

You don't have to restart the server if you change that value within Limesurvey. Apache only has to be restarted if you have edited its php.ini config file.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form