Check out the LimeSurvey source code on GitHub!

Can't create a survey....please I don't know what to do

6 years 2 weeks ago - 6 years 2 weeks ago #56796 by willylatorre
After configuring everything ok on a debian server, when i try to create a new survey I get the message

Warning: Invalid argument supplied for foreach() in /var/www/limesurvey/classes/adodb/adodb-lib.inc.php on line 806

Notice: Undefined variable: isrquery in /var/www/limesurvey/admin/database.php on line 1331

Query was empty


I think that everything is configured ok as I installed Limesurvey on different servers and I never had any issue.

php.ini is well configured
config.php also
and the database is created.

I don't know what to think. Please any ideas of what I should be looking for?

Thanks!

EDIT: If I try to import an already done survey, the following message appears

Error
An error occurred uploading your file. This may be caused by incorrect permissions in your /var/www/limesurvey/tmp folder.


Of course I changed all the permissions of the folder and the error keeps popping.

Please Log in to join the conversation.

6 years 2 weeks ago #56841 by Mazi
1. Which Limesurvey version do you use?

2. Please re-upload all files in binary mode, maybe a file was broken during upload.

3. Please switch on debug mode by adding the following line to your config.php file:
$debug = '1';

Are there any additional errors reported on top of the page?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

6 years 1 week ago #57034 by willylatorre
Thanks for awnsering

1. I use the last one 1.90+

2. I have already re-uploaded it several times. And it doesn't change anything.

3. I have already switched to debug mode. This message is from the debug mode.


Maybe I can try to install an older version? Where can I get it? Thanks!

Please Log in to join the conversation.

6 years 1 week ago #57042 by Mazi
1. Try to re-upload all files in binary mode, maybe a file was broken during upload.

2. Check permissions once more. Often servers are configured too strictly so they don't allow scripts to create and/or write files though the folder is theoretically writeable.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

5 years 11 months ago - 5 years 11 months ago #58206 by willylatorre
Thanks, It was some permission related thing. I followed that guide and everything went fine!

Install Limesurvey in ubuntu

Thanks again for your time

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form