Cannot import survey that is earlier imported from 1.87

More
6 years 5 months ago #57786 by joop
joop replied the topic: Cannot import survey that is earlier imported from 1.87
I solved all my problems.
The error message when importing the specific survey, was caused by the configuration of PHP. The imported survey was to big. I solved this by changing the upload_max_filesize setting in the php.ini from 2M to 20M.
Still the limesurvey error message is quit confusing:
An error occurred uploading your file. This may be caused by incorrect permissions in your /var/www/html/limesurvey/tmp folder.

To be able to import and copy my survey (earlier imported from 1.87) I still had to solve my character set problem. I first changed the driver back from 'odbc_mssql' to 'mssql_n', as the odbc driver gave lots of other troubles. Then I adapted the PHP configuration by changing the mssql.charset parameter to UTF-8. This forced freetds to use the UTF-8 character set.

After this my limesurvey installation was working properly with new created surveys. My existing survey (earlier imported from 1.87) was still giving problems. Therefore I had to replace manually all strange characters from the export file (.lss). Because of my chracter set problem all the special characters like ë, ï, é,`,ö etc. where misshapen.

Please Log in to join the conversation.

More
4 years 10 months ago #85609 by versiona
versiona replied the topic: Cannot import survey that is earlier imported from 1.87
Hello,

This post is old but I resolve the same problem by simply inscrease:

upload_max_filesize

in php.ini. In my case I put 10M (10 megabytes)

Hope that help someone!

Alan

Please Log in to join the conversation.

More
1 year 6 months ago #130327 by codelogic
codelogic replied the topic: Cannot import survey that is earlier imported from 1.87
Thank you so much this was very helpful.

Please Log in to join the conversation.

Did you already participate in our customer survey?

Don't miss your chance for great prices.

Please click here to participate:

Start now

Start now!

Just create your account and start using Limesurvey today.

Register now