Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Admin login goes to "fatal error" but database set up

Admin login goes to "fatal error" but database set up 5 years 10 months ago #55977

  • krsanna
  • krsanna's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
I installed 1.90 last night and the database sets up fine and admin page comes up, but everytime I try to login it goes to a blank page and fatal error. Help! I do not get the message about characters, like (). It just gives me the 404 fatal error. Thank you.
The administrator has disabled public write access.

Admin login goes to "fatal error" but database set up 5 years 10 months ago #55982

  • holch
  • holch's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 5413
  • Thank you received: 806
  • Karma: 239
What did you set as root_url in the config.php?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | [url=https://manual.limesurvey.org/Workarounds[/url]

If you found this answer helpful and it saved you some time please consider a [url=https://donate.limesurvey.org[/url] to the...
The administrator has disabled public write access.

Admin login goes to "fatal error" but database set up 5 years 10 months ago #55984

  • krsanna
  • krsanna's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
The administrator has disabled public write access.

Admin login goes to "fatal error" but database set up 5 years 10 months ago #55989

  • holch
  • holch's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 5413
  • Thank you received: 806
  • Karma: 239
Looks like there is something wrong with the root_url.

Leave it as it is (don't put the domain), limesurvey will find it's way.

So I have seen that you have installed Limesurvey under www.timestar.org/limesurvey

I can see there, that the images and CSS is missing. That shows me, that the path is not correct.

This is what you should put into your $roolurl, if your limesurvey files are located under www.timestar.org/limesurvey:
$rooturl = "http://{$_SERVER['HTTP_HOST']}/limesurvey";

Try it with the exact term above, leaving {$_SERVER} as it is. This should work.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | [url=https://manual.limesurvey.org/Workarounds[/url]

If you found this answer helpful and it saved you some time please consider a [url=https://donate.limesurvey.org[/url] to the...
The administrator has disabled public write access.

Admin login goes to "fatal error" but database set up 5 years 10 months ago #56003

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6027
  • Thank you received: 373
  • Karma: 260
Problem solved?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"
The administrator has disabled public write access.

Admin login goes to "fatal error" but database set up 5 years 10 months ago #56062

  • krsanna
  • krsanna's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Yes, thank you. The root url that ended up working was: "timestar.org/public_html/limesurvey"

I'm happily working away on the survey now. Thanks, again.
The administrator has disabled public write access.

Admin login goes to "fatal error" but database set up 5 years 10 months ago #56063

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6027
  • Thank you received: 373
  • Karma: 260
That is a very strange rooturl, but as long as it works fine...

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"
The administrator has disabled public write access.

Admin login goes to "fatal error" but database set up 5 years 10 months ago #56088

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9551
  • Thank you received: 1370
  • Karma: 389
Mazi wrote:
That is a very strange rooturl, but as long as it works fine...
Actually
timestar.org/limesurvey/admin/admin.php seems OK :dry:
Assistance on LimeSurvey forum and LimeSurvey core development are on my free time (Need support ?).
A bug not reported is a bug not corrected. | 2.61lts version improved | Need plugins for LimeSurvey ?
The administrator has disabled public write access.
Time to create page: 0.352 seconds
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form