Check out the LimeSurvey source code on GitHub!

502 proxy error

More
6 years 4 weeks ago #55642 by rinaaz
Hi..

I am still newbie with the limesurvey..

Here is the error :

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /limesurvey/admin/install/index.php.

Reason: Error reading from remote server

Apache/2.2.3 (Red Hat) Server at xxxxxx Port 80

ScubaMummy

Please Log in to join the conversation.

More
6 years 4 weeks ago #55663 by Mazi
1. Which Limesurvey version are we talking about?

2. Could you run the install script correctly?

3. When does the error show up (URL?)?

4. Which URL do you use to log in at the admin backend and what did you set as $rooturl in config.php?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 4 weeks ago - 6 years 4 weeks ago #55665 by rinaaz

Mazi wrote: 1.

Which Limesurvey version are we talking about?

I am using limesurvey version 1.90

2. Could you run the install script correctly?

don't understand on this.

3. When does the error show up (URL?)?

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /limesurvey/test.php.

Reason: Error reading from remote server

Apache/2.2.3 (Red Hat) Server at xxx.xxx.xx.xx Port 80


4. Which URL do you use to log in at the admin backend and what did you set as $rooturl in config.php?


"http://{$_SERVER}/limesurvey";

ScubaMummy
Last Edit: 6 years 4 weeks ago by rinaaz.

Please Log in to join the conversation.

More
6 years 4 weeks ago #55671 by holch

rinaaz wrote:

Mazi wrote: 1.

Which Limesurvey version are we talking about?

I am using limesurvey version 1.90

2. Could you run the install script correctly?

don't understand on this.

Mazi is trying to narrow down when and where the error appears. So he wants to know if you were able to run the installation script of limesurvey without problems, or if the installation was not sucessful / with error message.

3. When does the error show up (URL?)?

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /limesurvey/test.php.

Reason: Error reading from remote server

Apache/2.2.3 (Red Hat) Server at xxx.xxx.xx.xx Port 80


This is the error message, but does not explain WHEN the error message appears. It would be good to know what leads to that error message. Please describe as detailed as possible. Otherwise it is almost impossible to help you, because it would always be only guesswork.

4. Which URL do you use to log in at the admin backend and what did you set as $rooturl in config.php?


"http://{$_SERVER}/limesurvey";


I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 4 weeks ago #55681 by Mazi
2. When following the installation instructions ( docs.limesurvey.org/Installation&structu...r+LimeSurvey&no_bl=y ) have there been any problems?

3. What script is "test.php" (limesurvey/test.php)?

5. Can you post the link to the admin login scrren of your system?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 3 weeks ago #55695 by rinaaz

holch wrote:

rinaaz wrote:

Mazi wrote: 1.

Which Limesurvey version are we talking about?

I am using limesurvey version 1.90

2. Could you run the install script correctly?

don't understand on this.

Mazi is trying to narrow down when and where the error appears. So he wants to know if you were able to run the installation script of limesurvey without problems, or if the installation was not sucessful / with error message.

3. When does the error show up (URL?)?

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /limesurvey/test.php.

Reason: Error reading from remote server

Apache/2.2.3 (Red Hat) Server at xxx.xxx.xx.xx Port 80


This is the error message, but does not explain WHEN the error message appears. It would be good to know what leads to that error message. Please describe as detailed as possible. Otherwise it is almost impossible to help you, because it would always be only guesswork.

4. Which URL do you use to log in at the admin backend and what did you set as $rooturl in config.php?


"http://{$_SERVER}/limesurvey";


The error message appeared when we tried to login http://localhost/test.php

ScubaMummy

Please Log in to join the conversation.

More
6 years 3 weeks ago #55696 by rinaaz

Mazi wrote: 2. When following the installation instructions ( docs.limesurvey.org/Installation&structu...r+LimeSurvey&no_bl=y ) have there been any problems?

I have done all of this configuration based on this steps.

3. What script is "test.php" (limesurvey/test.php)?

[root@kpwkmapp limesurvey]# more test.php
<?php
echo "Hello, World!";
?>
[root@kpwkmapp limesurvey]#

5. Can you post the link to the admin login scrren of your system?


Link to jboss admin ? Will be go straight to the portal.

ScubaMummy

Please Log in to join the conversation.

More
6 years 3 weeks ago #55737 by holch
Hmmm, I am a little confused. In a normal limesurvey installation, there is no test.php. Where is this coming from, and why do you need it?

I am not sure what you are referring to with jboss admin??

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 years 3 weeks ago #55866 by Mazi
I'm also stuck here. The test.php file won't cause any problems, it's just for testing if PHP runs fine.

Try to access the system for a different computer (maybe at home) because there might be some proxy (at your company) that causes problems.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form