Check out the LimeSurvey source code on GitHub!

PHP errors after install but BEFORE first logon

More
6 years 1 month ago #53585 by natcen
Hi All,
Any help with this would be much appreciated. I have installed Limesurvey OK and the database is working well. However, when the install is complete I get PHP fatal errors. This happens after the point where you rename/move the admin/install folder and attempt to run admin/admin.php.

I have set the debug mode to 2 to display the following error:

Fatal error: session_start() [<a href='function.session-start'>function.session-start</a>]: Failed to initialize storage module: user (path: ) in ~~~~~~~~~\limesurvey\admin\sessioncontrol.php on line 36

Has anyone any ideas? I have checked my PHP setup and all of the required libraries and add ons are available.

Running IIS 6.0 (requirement of the company)
PHP 5.2
MSSQL

Many thanks

Please Log in to join the conversation.

More
6 years 1 month ago #53589 by Mazi
Pklease check if the "session.save_path" set in php.ini is correct. The folder listed there has to exist and has to be writeable.

Maybe searching the installation FAQ for "session" will reveal further information: docs.limesurvey.org/tiki-index.php?page=...tions+for+LimeSurvey


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form