Problems to login as admin

More
6 years 9 months ago #55037 by mgspielman
mgspielman replied the topic: Problems to login as admin
Returning to this issue after a break for Christmas. Basically, I am the System Admin. Or at least I do the best I can. Is there anything else you can tell me regarding the location of the php.ini file?

Please Log in to join the conversation.

More
6 years 6 months ago #59010 by isocs
isocs replied the topic: Problems to login as admin
:dry: I just met the same problem as yours almost two weeks ago. I even tried for several ten sites to test which one is good for limesurvery work well. But the results is always same, I can't login as admin, and always it came back the login webpage. Just when I want to find other method whether I don't know it would be ok, it is really made me head pained, some sound reminded me why not try the easiest possibility, last year when I first time tested limesurvey, it sound the config.php must be saving as utf-8, just like the special explanation in installation profile for limesurvey.

I should short my words: I found out the software named PSPad editor in my Win PC, edit the config.php for my site parameters, and saved it. Then transferred the file to the server, open the admin webpage. It worked now!

Finally I understood when original time I install limesurvey to the sites, I am lazy, just used the Notpad of Win to save the config.php, but in fact, Notpad changed the file format silentally although it said would be save the file to utf-8. That is the true reason why I can't login as admin, just like what mentioned in the installation profile of limesurvey.

So, at first, try the PSPad editor to keep your config.php as true utf-8 format, then test others.

Now almost all of my tested sites can smoothly running limesurvey, that's true limesurvey performance.

That is my funny story when I use the very nice software limesurvey, it sounds just like the story about tailor fighting with the huge human-being through the magic bean, hahaha!

Thanks for your time to read my words, and hope these is useful for your.

Good luck! always!

Please Log in to join the conversation.

More
6 years 6 months ago #59020 by DenisChenu
DenisChenu replied the topic: Problems to login as admin
isocs :

Thnaks for the information !

A great information !

Can you put this to our documentation please ?

I think here is the best choice : docs.limesurvey.org/Installation+FAQ

:)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
6 years 6 months ago #59570 by mgspielman
mgspielman replied the topic: Problems to login as admin
I just re-output a new config file as suggested and I'm now able to login to my admin page. However, after logging in to admin, it tells me no surveys are available. The survey is still running correctly on my website. Why can't I see it in admin?

Please Log in to join the conversation.

More
5 years 9 months ago #71514 by vinodlime
vinodlime replied the topic: Problems to login as admin
Hi Guys , I have same problem , I tried by saving the config file in UTF-8 format. But the issue still exists . Please help.

The same issue was there in my local host and that is corrected when I commented this line session_regenerate_id(); in the line 173 of usercontrol.php

But in the server, that does not help.

I am worried

thanks
Vinod

Please Log in to join the conversation.

More
5 years 9 months ago #71563 by Mazi
Mazi replied the topic: Problems to login as admin
Vinod,

1. Which Limesurvey version do you use?

2. Can you describe your problem in detail (step by step)?

3. Please switch on debug mode by adding the following line to your config.php file:
$debug = '1';

Are there any additional errors reported on top of the page?

4. Please upload a phpinfo file so we can take a look at your server configuration. Just put the following code into a file named phpinfo.php and upload it to your webserver:
< ?php phpinfo(); ? >
(Delete the spaces next to </> when copying the code.)
After uploading please post the link to the file.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
5 years 9 months ago #71683 by vinodlime
vinodlime replied the topic: Problems to login as admin
@Mazi

Finally issue is solved

I have activate debug mode and tried. then I found the session file it is accessing is not present.

The I used session_save_path(), in the top of the config.php ; for setting the session save path

This worked

Thanks Mazi , for trying to help me

Please Log in to join the conversation.

More
5 years 9 months ago #71686 by Mazi
Mazi replied the topic: Problems to login as admin
Thanks for your feedback.

Can you please update the installation FAQ so that other users will benefit from your findings, too: docs.limesurvey.org/Installation+FAQ

Thanks!


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 9 months ago #90578 by lukasso8eu
lukasso8eu replied the topic: Problems to login as admin
Hallo,
there is a problem with my limesurvey installation. Always i want to log in as admin (I don't have another accounts yet)it will return me back to the login-page with fields cleared. I have right password, because when I try another one, it will tell me, that I have wrong password. I all started i think, when I couldn't log in with my old password (which I have chosen after instalation), so i have followed the change-password procedure.

Does anybody know, how to solve it?
I have even tried to put on the debug mode (by putting the $debug = '1'; line to the config.php), but the situation was totally the same.
I have a pdf with phpinfo results I can send, if someone would be interested.

Please Log in to join the conversation.

More
4 years 9 months ago - 4 years 9 months ago #90580 by Mazi
Mazi replied the topic: Problems to login as admin
I just linked the Installation FAQ above (docs.limesurvey.org/installation+FAQ). So this should be a good first start, especially since this exactly sounds like your problem: " Any action in admin page will return you to login screen "


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"
Last Edit: 4 years 9 months ago by Mazi.

Please Log in to join the conversation.

More
4 years 9 months ago #90584 by lukasso8eu
lukasso8eu replied the topic: Problems to login as admin
Thank you for you help, but those I have tried.
I tried it in chrome, IE and opera, a i have already checked, if the config.php is in ANSI.
But i don't know how to check, if there isn't any problem with sessions, when I'm just a guy working on a school project, on school servers.
Would be helpful for you, if I'd message you the phpinfo?

Really thanks for help.

Please Log in to join the conversation.

More
4 years 9 months ago #90585 by Mazi
Mazi replied the topic: Problems to login as admin

lukasso8eu wrote: But i don't know how to check, if there isn't any problem with sessions, when I'm just a guy working on a school project, on school servers.
Would be helpful for you, if I'd message you the phpinfo?

Definitely!

Also check if the folder defined at the "session.save_path" setting exists and is writable.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 9 months ago #90587 by lukasso8eu
lukasso8eu replied the topic: Problems to login as admin
I really appreciate your help. I just sent you pdf with the php info.
I also don't know, where to find this session.save_path. In which file it is?
Thank you very much ..

Please Log in to join the conversation.

More
4 years 9 months ago #90590 by Mazi
Mazi replied the topic: Problems to login as admin
I don't see any PDf file here, please post it here.

As for the save_path setting: That can be found at the php.ini configuration file of your webserver.
Tell your provider to check and fix this if necessary. Your problem description indicates that this might cause the trouble.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 9 months ago - 4 years 9 months ago #90643 by lukasso8eu
lukasso8eu replied the topic: Problems to login as admin
Here is my php info ... Im going to write to the admin of our servers.
here: survey.natur.cuni.cz/phpinfo.php
Last Edit: 4 years 9 months ago by lukasso8eu.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now