Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Problems to login as admin

Problems to login as admin 5 years 2 months ago #52669

  • arne
  • arne's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
I am now getting the following message at the top of the page:

Warning: session_regenerate_id() [function.session-regenerate-id]: Cannot regenerate session id - headers already sent in /mounted-storage/home56b/sub009/sc30889-YLYC/sinthubertusbeselare.be/poll/admin/usercontrol.php on line 133



Everytime I want to login I get re-directed back to the login page.

Can anyone help?
The administrator has disabled public write access.

Problems to login as admin 5 years 2 months ago #52818

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5840
  • Thank you received: 347
  • Karma: 261
arne wrote:
]
Everytime I want to login I get re-directed back to the login page.

Can anyone help?
Sounds like this problem: docs.limesurvey.org/tiki-index.php?page=..._you_to_login_screen

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Problems to login as admin 5 years 2 months ago #52859

  • sebnantes
  • sebnantes's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
hello,
i have the same problems with IIS, do you find a issue ?
I checked this list :
1.Update upload_tmp_dir and session.save_path in php.ini
2.Create the configured session and upload directories
3.IIS: Assigned permission to create and modify to IIS guest user account
4.Apache: Make sure your webserver has permissions to write into the configured directory
5.Check if the variable "session.use_cookies" in php.ini is set to 1.
6.Check the variable "session.auto_start" in php.ini. If it is set to 1, change it to 0.

all is ok but impossible to connect as admin !!!
thank
The administrator has disabled public write access.

Problems to login as admin 5 years 2 months ago #52877

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5840
  • Thank you received: 347
  • Karma: 261
Please upload a phpinfo file so we can take a look at your server configuration. Just put the following code into a file named phpinfo.php and upload it to your webserver:
< ?php phpinfo(); ? >
(Delete the spaces next to </> when copying the code.)
After uploading please post the link to the file.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Problems to login as admin 5 years 1 month ago #54111

  • mgspielman
  • mgspielman's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
I'm having the same issue. Survey is working, but I can't login into admin. Here's my phpinfo:

http://www.abort73.com/phpinfo.php

Please advise.
The administrator has disabled public write access.

Problems to login as admin 5 years 1 month ago #54138

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5840
  • Thank you received: 347
  • Karma: 261
File not found, mgspielman?!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Problems to login as admin 5 years 1 month ago #54158

  • mgspielman
  • mgspielman's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Sorry, I didn't want to leave the file up for security reasons. I just PM'd you a link to a PDF of the server config.
The administrator has disabled public write access.

Problems to login as admin 5 years 1 month ago #54166

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5840
  • Thank you received: 347
  • Karma: 261
mgspielman, which of the sugestion linked above (docs.limesurvey.org/tiki-index.php?page=..._you_to_login_screen) did you test?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Problems to login as admin 5 years 1 month ago #54171

  • mgspielman
  • mgspielman's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
I'm not sure how to test the PHP stuff. Where is the php.ini file?

I'm not using IE. I hadn't edited the config file since the login problem started happening, though I did reset my password to see if that helped. It didn't.
The administrator has disabled public write access.

Problems to login as admin 5 years 1 month ago #54179

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5840
  • Thank you received: 347
  • Karma: 261
Forward the link above to your system admin, he should now how to edit the php.ini file according to the suggestions in the manual.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Problems to login as admin 5 years 4 weeks ago #55037

  • mgspielman
  • mgspielman's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Returning to this issue after a break for Christmas. Basically, I am the System Admin. Or at least I do the best I can. Is there anything else you can tell me regarding the location of the php.ini file?
The administrator has disabled public write access.

Problems to login as admin 4 years 10 months ago #59010

  • isocs
  • isocs's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
:dry: I just met the same problem as yours almost two weeks ago. I even tried for several ten sites to test which one is good for limesurvery work well. But the results is always same, I can't login as admin, and always it came back the login webpage. Just when I want to find other method whether I don't know it would be ok, it is really made me head pained, some sound reminded me why not try the easiest possibility, last year when I first time tested limesurvey, it sound the config.php must be saving as utf-8, just like the special explanation in installation profile for limesurvey.

I should short my words: I found out the software named PSPad editor in my Win PC, edit the config.php for my site parameters, and saved it. Then transferred the file to the server, open the admin webpage. It worked now!

Finally I understood when original time I install limesurvey to the sites, I am lazy, just used the Notpad of Win to save the config.php, but in fact, Notpad changed the file format silentally although it said would be save the file to utf-8. That is the true reason why I can't login as admin, just like what mentioned in the installation profile of limesurvey.

So, at first, try the PSPad editor to keep your config.php as true utf-8 format, then test others.

Now almost all of my tested sites can smoothly running limesurvey, that's true limesurvey performance.

That is my funny story when I use the very nice software limesurvey, it sounds just like the story about tailor fighting with the huge human-being through the magic bean, hahaha!

Thanks for your time to read my words, and hope these is useful for your.

Good luck! always!
The administrator has disabled public write access.

Problems to login as admin 4 years 10 months ago #59020

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 8218
  • Thank you received: 1122
  • Karma: 333
isocs :

Thnaks for the information !

A great information !

Can you put this to our documentation please ?

I think here is the best choice : docs.limesurvey.org/Installation+FAQ

:)
The administrator has disabled public write access.

Problems to login as admin 4 years 9 months ago #59570

  • mgspielman
  • mgspielman's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
I just re-output a new config file as suggested and I'm now able to login to my admin page. However, after logging in to admin, it tells me no surveys are available. The survey is still running correctly on my website. Why can't I see it in admin?
The administrator has disabled public write access.

Problems to login as admin 4 years 1 month ago #71514

  • vinodlime
  • vinodlime's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Hi Guys , I have same problem , I tried by saving the config file in UTF-8 format. But the issue still exists . Please help.

The same issue was there in my local host and that is corrected when I commented this line session_regenerate_id(); in the line 173 of usercontrol.php

But in the server, that does not help.

I am worried

thanks
Vinod
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.196 seconds