Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:
  • Page:
  • 1
  • 2

TOPIC: "Incorrect username and/or password" What's wrong?

"Incorrect username and/or password" What's wrong? 5 years 8 months ago #52514

  • Alexlion
  • Alexlion's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Hello, support team!

I followed your installation guide and finally managed to install this beast. But there's another problem now. I get "Incorrect username and/or password!" And I suspect it is something with redirecting(?), or maybe not.
So here it goes:

I installed it in mysite.com/survey/limesurvey/admin/admin.php

But when I enter username and password, url always jumps to mysite.com/limesurvey/admin/admin.php for some reason.

$rooturl = mysite.com/survey/limesurvey

$databasename and $databaseuser in config.php are the same as mysql database name and username I created.
$databasename = 'revenuea_mandy';
$databaseuser = 'revenuea_mandy';

$databasepass is the same as mysql user pass too. I just entered all the same data for simplicity sake.
Maybe I can't use same database and user name?

Almost forgot, when Installed I was asked to remove admin/install.php (or something like that), I deleted it (install directory). Though probably it doesn't connect with the problem.

I also changed default pass and username, but then I changed it back to "admin" and "password", because it doesn't work either.

When I try to enter default user/pass OR my databaseuser/name and pass, it gives me "Incorrect username and/or password!"

I probably missed something important. But please help.

Regards,
Aleks

p.s. - didn't found that problem in the forum too.
The administrator has disabled public write access.

"Incorrect username and/or password" What's wrong? 5 years 8 months ago #52515

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5063
  • Thank you received: 749
  • Karma: 227
Try this as rooturl:
$rooturl  =  "http://{$_SERVER['HTTP_HOST']}/survey/limesurvey ";
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

"Incorrect username and/or password" What's wrong? 5 years 8 months ago #52590

  • Alexlion
  • Alexlion's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
I just reinstalled this thing completely. All worked beautifully from first time, but I still get the same message!
I put your code before installing, and didn't changed or edit anything. Just completely followed installation process, and it worked.. till login.
Here is all info.

$databaselocation = 'localhost';
$databasename = 'revenuea_mandy';
$databaseuser = 'revenuea_mandy'; - this is what I enter in username
$databasepass = 'mandy007'; - this is what I enter in password..
$dbprefix = 'lime_';
$rooturl = "http://{$_SERVER}/survey/limesurvey";
$rootdir = dirname(__FILE__);
$defaultuser = 'admin';
$defaultpass = 'password';

What is wrong?... I tried many times, with default user and pass too.. Don't work.. By the way this time there was no redirecting or anything.

Regards,
Aleks
Last Edit: 5 years 8 months ago by Alexlion.
The administrator has disabled public write access.

"Incorrect username and/or password" What's wrong? 5 years 8 months ago #52593

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5063
  • Thank you received: 749
  • Karma: 227
What do you get to see when you navigate to mysite.com/survey/limesurvey ?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

"Incorrect username and/or password" What's wrong? 5 years 8 months ago #52594

  • Alexlion
  • Alexlion's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
LimeSurvey

The following surveys are available:

* No available surveys

Please contact Your Name ( This email address is being protected from spambots. You need JavaScript enabled to view it. ) for further assistance.

[LimeSurvey Survey Software]
The Online Survey Tool - Free & Open Source
The administrator has disabled public write access.

"Incorrect username and/or password" What's wrong? 5 years 8 months ago #52595

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5063
  • Thank you received: 749
  • Karma: 227
Yes, but can you make a screen shot?

Are there all images shown or are some not loaded (placeholder shows)?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

"Incorrect username and/or password" What's wrong? 5 years 8 months ago #52598

  • Alexlion
  • Alexlion's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Here it is. I hope together we will be able to fix it.

Edit: oups.. not appeared. Wait a sec..
Last Edit: 5 years 8 months ago by Alexlion.
The administrator has disabled public write access.

"Incorrect username and/or password" What's wrong? 5 years 8 months ago #52599

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5063
  • Thank you received: 749
  • Karma: 227
Hmm, the pages looks fine, the graphics appear. I was asking because when there is something wrong with the rooturl (which happens quite a lot) those images usually don't show. So my suspicion was not right.

Unfortunately I have no other idea (besides a wrong password/login ;-) ) what it could be. Let's see if someone else has a better idea.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

"Incorrect username and/or password" What's wrong? 5 years 8 months ago #52600

  • Alexlion
  • Alexlion's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Maybe I can't have mysql database with same user/password?
The administrator has disabled public write access.

"Incorrect username and/or password" What's wrong? 5 years 8 months ago #52601

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5063
  • Thank you received: 749
  • Karma: 227
What do you mean with that? Did you use the same password and user for the database and for the admin? I don't think that this should be a problem.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

"Incorrect username and/or password" What's wrong? 5 years 8 months ago #52610

  • Alexlion
  • Alexlion's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Firstly, I created database with same name and pass, then I put those in config.php and "installed" limesurvey. Though they said there exist such database already, so installation just let me in for logging.

Can't believe I can't run this program..
Last Edit: 5 years 8 months ago by Alexlion.
The administrator has disabled public write access.

"Incorrect username and/or password" What's wrong? 5 years 8 months ago #52619

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9259
  • Thank you received: 1320
  • Karma: 382
Hello,

Can you test with : admin / password ?

It's in config.php :)

You can change (and have to change) after be connected.
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

"Incorrect username and/or password" What's wrong? 5 years 8 months ago #52653

  • Alexlion
  • Alexlion's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Hello!

:( I tested with default user/pass too.. Just changed them, still doesn't work.. Hmm.. Maybe it's something with limesurvey version itself?

Edit: just checked.. nope :( Newest version - 1.90+, 22mb..
Last Edit: 5 years 8 months ago by Alexlion.
The administrator has disabled public write access.

"Incorrect username and/or password" What's wrong? 5 years 8 months ago #52655

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5063
  • Thank you received: 749
  • Karma: 227
I don't think that it is a problem of the limesurvey version. Maybe you didn't upload all files? (happens sometimes when uploading via FTP and you won't even notice it).

I would do the following (as it seems to be a new install with no surveys in it):
1. Delete all files on the server.
2. Delete the database and the database user.
3. Create a new database and a new database user
4. Upload the files, make sure everything is uploaded (compare file sizes locally and on the server)
5. Follow the installation process thoroughly.

All this shouldn't take you longer than 30 min (with file down- and upload). I think it is better than guessing.

If it doesn't work then, then I don't know...

Usually Limesurvey is pretty straight forward to install.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

"Incorrect username and/or password" What's wrong? 5 years 8 months ago #52656

  • Alexlion
  • Alexlion's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
I just uploaded all archive through cpanel... Maybe. I will do that steps now.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.277 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form