Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Multiple choice questions not working!

Multiple choice questions not working! 6 years 1 month ago #51007

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6027
  • Thank you received: 373
  • Karma: 260
Ahh, thanks for catching up on this. Hopefully this will be solved in the future.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 1 month ago #51079

  • peteb
  • peteb's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Hi Mazi.

Just to conclude this, my host has commented out the rule in mod_security and everything is working fine.
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 1 month ago #51082

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6027
  • Thank you received: 373
  • Karma: 260
You're welcome!

If our hints have been helpful and you enjoy limesurvey please consider a donation to the team .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 1 month ago #51372

Hi, This is how our host solved this issue: I don´t understand any of it but now it works anyway B)

Remove the mod_security rule from config (mod_sec/apache config) or disable
mod_Security via .htaccess. For some reason we could not disable via .htaccess
so we just removed the rule from mod-sec config.

Search apache error_log after jquery.cookie.js and you will find details.

ModSecurity: Access denied with code 406 (phase 2).
Pattern match ....."a lot of stuff, can't post it here, will be blocket in helpdesk etc"....
[id "950004"] [msg "Cross-site Scripting (XSS) Attack. Matched signature " ] [severity "CRITICAL"] [hostname "web04.wopsa.se"] [uri "/lime/scripts/jquery/j
query.cookie.js"] [unique_id "TMWCcFV2zh4AABi1fU0AAAAM"]
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 1 month ago #51594

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6027
  • Thank you received: 373
  • Karma: 260
Thanks for your feedback!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 1 month ago #51628

  • normington
  • normington's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
@OrangeIsBigger, thanks so much! I copied and pasted what you said and sent it to my host for them to execute, and now it works!

Problem solved, thanks to everybody.
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 1 month ago #51640

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6027
  • Thank you received: 373
  • Karma: 260
You're welcome!

If our hints have been helpful and you enjoy limesurvey please consider a donation to the team .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"
The administrator has disabled public write access.

Multiple choice questions not working! 5 years 7 months ago #59498

  • xabungo
  • xabungo's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
I was having the same problem.
It was a mod_security rule call a10_asl_rules.
here is the error:
Access denied with code 403 (phase 2). Pattern match "(< ?(?:script|about|applet|activex|chrome).*(?:script|about|applet|activex|chrome) ?>|> ?< ?(img ?src|a ?href) ?= ?(ht|f)tps?:/|" ?> ?<|" ?[a-z]+ ?<.*>|> ?"? ?(>|<)|< ?/?i?frame|\%env)" at ARGS:move2. [line "690"] [id "340147"] [rev "56"] [msg "Atomicorp.com - FREE UNSUPPORTED DELAYED FEED - WAF Rules: Generic XSS filter"] [data ""] [severity "CRITICAL"] I disable the mod security for that domain and limesurvey went perfect. but the domain is insecure now...... lets see what happens! Best regards Ricardo Dias[file "/usr/local/apache/conf/modsec/10_asl_rules.conf"] [line "690"] [id "340147"] [rev "56"] [msg "Atomicorp.com - FREE UNSUPPORTED DELAYED FEED - WAF Rules: Generic XSS filter"] [data ""] [severity "CRITICAL"]


I disable the mod security for that domain and limesurvey went perfect.
but the domain is insecure now...... lets see what happens!

Best regards

Ricardo Dias
Last Edit: 5 years 7 months ago by xabungo.
The administrator has disabled public write access.
Time to create page: 0.290 seconds
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form