Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Multiple choice questions not working!

Multiple choice questions not working! 6 years 2 months ago #48864

  • normington
  • normington's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
Hi,

Have installed limesurvey to my own site, and everything's working fine except one thing - I can't add more than one option to a multiple-choice question! When I select list (radio) as the question type (or multiple answers as the question type), the plus, minus and quick add buttons all don't work - nothing happens when I click them. Is there some broken javascript I can check for or something?

Thanks,
Andrew
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 2 months ago #48866

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5446
  • Thank you received: 814
  • Karma: 240
Check if all files are uploaded correctly. It sometimes happens that not all files are uploaded and then some parts of the tool don't work. Make sure there is the same amount of files uploaded to the server than you have unzipped locally. Then also make sure that the files are the same size.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | [url=https://manual.limesurvey.org/Workarounds[/url]

If you found this answer helpful and it saved you some time please consider a [url=https://donate.limesurvey.org[/url] to the...
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 2 months ago #48868

  • normington
  • normington's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
Hi,

Thanks for your help. Only differences between original zip and installed set of files are two very slight things: size of config.php and an extra file in \tmp labelled template_temp_100918113312.html. I don't imagine either of these are causing the problem? Infact the size change of config.php was quite deliberate, in me adding the configuration details of my site.

Any other ideas?

Andrew
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 2 months ago #48870

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5446
  • Thank you received: 814
  • Karma: 240
No, these 2 files shouldn't make a difference. The config file was modified, so it is just normal that it has a different size. Sorry, should have mentioned that before.

Could you show a screenshot of how it looks like?
Which version of LS do you use?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | [url=https://manual.limesurvey.org/Workarounds[/url]

If you found this answer helpful and it saved you some time please consider a [url=https://donate.limesurvey.org[/url] to the...
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 2 months ago #48871

  • normington
  • normington's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
Here's a screenshot of the admin panel for the question's answer options. When I hit plus or minus, nothing happens.


I'm using v1.9 - it says build 9130. I downloaded it today so it should be the latest.
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 2 months ago #48872

  • normington
  • normington's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
my bad - picture didn't come out there, for some reason. You can see it here instead: filedump.andrewnormington.co.uk/ls_2.png
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 2 months ago #48873

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5446
  • Thank you received: 814
  • Karma: 240
Sorry, no screenshot. You probably ran into the upload limit, which is something like 800px.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | [url=https://manual.limesurvey.org/Workarounds[/url]

If you found this answer helpful and it saved you some time please consider a [url=https://donate.limesurvey.org[/url] to the...
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 2 months ago #48874

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5446
  • Thank you received: 814
  • Karma: 240
OK, looks just normal on th screenshot. Just had a look at my installation, which I had updated recently, but is only 9118 and it works just fine. By clicking on plus there shows a new input field.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | [url=https://manual.limesurvey.org/Workarounds[/url]

If you found this answer helpful and it saved you some time please consider a [url=https://donate.limesurvey.org[/url] to the...
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 2 months ago #48875

  • normington
  • normington's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
Sure. No other ideas as to why it's not working properly?
I'm going to try installing again to another directory & db etc, and if that doesn't work I'll try an older build.
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 2 months ago #48876

  • normington
  • normington's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
Still didn't work after a reinstall. Sourceforge shoots right back to 1.87+ before build 9130 - do you still have a zip of 9118 that you could give me?

Thanks,
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 2 months ago #48877

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5446
  • Thank you received: 814
  • Karma: 240
Hi, I updated via the quick update function, and I don't have any zip file with an older version left, sorry.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | [url=https://manual.limesurvey.org/Workarounds[/url]

If you found this answer helpful and it saved you some time please consider a [url=https://donate.limesurvey.org[/url] to the...
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 2 months ago #48878

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5446
  • Thank you received: 814
  • Karma: 240
What is weird is that I checked for updates through the interface and there is no update...
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | [url=https://manual.limesurvey.org/Workarounds[/url]

If you found this answer helpful and it saved you some time please consider a [url=https://donate.limesurvey.org[/url] to the...
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 2 months ago #48935

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6029
  • Thank you received: 373
  • Karma: 260
Please upload a phpinfo file so we can take a look at your server configuration. Just put the following code into a file named phpinfo.php and upload it to your webserver:
< ?php phpinfo(); ? >
(Delete the spaces next to </> when copying the code.)
After uploading please post the link to the file.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 2 months ago #48969

  • normington
  • normington's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
The administrator has disabled public write access.

Multiple choice questions not working! 6 years 2 months ago #49012

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6029
  • Thank you received: 373
  • Karma: 260
Config looks fine. Is there anything listed at the servers error log?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"
The administrator has disabled public write access.
Time to create page: 0.356 seconds
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form