Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:
  • Page:
  • 1
  • 2

TOPIC: Not Able to Add or Edit Questions on new 1.90 ????

Not Able to Add or Edit Questions on new 1.90 ???? 6 years 2 weeks ago #46435

  • pmontanez
  • pmontanez's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Hi Folks,

I just update to 1.90 version .. but it seems that the new AJAX component is not working with my browsers ( IE, Oper, Fire). I'm able to get into the Edit Answers Area but when I click on Add question or Remove or any other future ...it doesn't do anything..

Please Advice... I'm getting my brains out !!!!


Thanks in advance!!!


Regards,

Peter.
The administrator has disabled public write access.

Not Able to Add or Edit Questions on new 1.90 ???? 6 years 2 weeks ago #46444

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5984
  • Thank you received: 368
  • Karma: 260
1. Please switch on debug mode by adding the following line to your config.php file:
$debug = '1';

Are there any additional errors reported on top of the page?

2. Can you reproduce the problem at all question types?

3. Maybe re-uploading the files in binary mode msolves the problem.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Not Able to Add or Edit Questions on new 1.90 ???? 6 years 2 weeks ago #46445

  • mdekker
  • mdekker's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 343
  • Thank you received: 68
  • Karma: 38
Do you get any javascript errors?
---
Menno Dekker
The administrator has disabled public write access.

Not Able to Add or Edit Questions on new 1.90 ???? 6 years 2 weeks ago #46452

  • pmontanez
  • pmontanez's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
I was chating this aftenoon with Mr.. schmitz this afternoon for some reason I can't read /scripts/jquery/jquery.cookie.js all other scripts are readable without any trouble... I contacted my vhosting they said that is not from their side...

I think that I'm gonna try to upload the whole files again in binary mode again ( I just used the uncompress option from vhost file manager)

We'll keep post it

Thank for your help!!!
The administrator has disabled public write access.

Not Able to Add or Edit Questions on new 1.90 ???? 6 years 2 weeks ago #46453

  • pmontanez
  • pmontanez's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Guys problem solve (Maybe you want to keep this post sticky as a lot people use Justhost or Lunarpages )

They have to deactivated the mod_security for the domain name. Otherwise the AJAX jquery will not render on the browser...

Thanks for your help.. and keep it up with your great Job..

Regards,


Peter.

Ps: Special thanks to C_Schmitz !!!
The administrator has disabled public write access.

Not Able to Add or Edit Questions on new 1.90 ???? 6 years 2 weeks ago #46472

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5984
  • Thank you received: 368
  • Karma: 260
You're welcome!

If our hints have been helpful and you enjoy limesurvey please consider a donation to the team .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Not Able to Add or Edit Questions on new 1.90 ???? 5 years 11 months ago #49144

  • luc_dubois
  • luc_dubois's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Same problem with HostPapa. I've ask to change the MOD_SECURITY and it work fine now...
The administrator has disabled public write access.

Not Able to Add or Edit Questions on new 1.90 ???? 5 years 11 months ago #49158

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5984
  • Thank you received: 368
  • Karma: 260
luc_dubois wrote:
Same problem with HostPapa. I've ask to change the MOD_SECURITY and it work fine now...
Thanks a lot for your feedback. Can you add this to our wiki so that other users can benefit from your solution, too? Would be great!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Not Able to Add or Edit Questions on new 1.90 ???? 5 years 11 months ago #49165

Can you plaes explain in detail what you mean with:
deactivated the mod_security for the domain name

I think this can be a solution for some problems I had.

Thanks, Fred
The administrator has disabled public write access.

Not Able to Add or Edit Questions on new 1.90 ???? 5 years 11 months ago #49212

  • luc_dubois
  • luc_dubois's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Sure, but where in the wiki ?
The administrator has disabled public write access.

Not Able to Add or Edit Questions on new 1.90 ???? 5 years 11 months ago #49215

  • luc_dubois
  • luc_dubois's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Basicaly, with your web provider you open a ticket and ask them to check the MOD_SECURITY configuration.

Link this post to youre ticket so they have a better picture.

That's it !

For Hostpapa, there respond was 1 day after I ask. I received this email :

"
Hello,

It looks like mod_security was causing this issue and should be fixed now. Please let me know if you are still encountering this problem.

Thanks,
Joe
Systems Administrator
"
The administrator has disabled public write access.

Not Able to Add or Edit Questions on new 1.90 ???? 5 years 11 months ago #49219

  • pmontanez
  • pmontanez's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
You need to contact your hosting company and ask then to remove MOD_SECURITY from your domain. otherwise the jquery will not render.. you wont be able to add the questions to your survey.
The administrator has disabled public write access.

Not Able to Add or Edit Questions on new 1.90 ???? 5 years 11 months ago #49227

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5984
  • Thank you received: 368
  • Karma: 260
pmontanez, luc_dubios, please add this advice at the "installation FAQ" page of our wiki.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Not Able to Add or Edit Questions on new 1.90 ???? 5 years 10 months ago #50100

  • zamba
  • zamba's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
pmontanez wrote:
You need to contact your hosting company and ask then to remove MOD_SECURITY from your domain. otherwise the jquery will not render.. you wont be able to add the questions to your survey.

Hi! I was following this post, because I have the same problem.

Yesterday I asked to my hosting company to remove mod_security. They are always very helpful, but this time answered that they can't do that, because it will affect the security of all other clients on the same server.

Is there any chance of fixing this without removing mod_security?

Considering that many LimeSurvey users may be in my same position, is it possible to release another update that avoid this problem?

Thank you for your time and help and sorry for my rusty English.

Regards,

Diego
The administrator has disabled public write access.

Not Able to Add or Edit Questions on new 1.90 ???? 5 years 10 months ago #50101

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5095
  • Thank you received: 756
  • Karma: 227
I remember Carsten, the project leader saying, that switching off this mod_security isn't doing any harm (not 100% sure though). But of course, this doesn't help you much if your hosting company doesn't want to do that. ;-)

However, I assume that it is necessary for some features of Limesurvey, otherwise I am quite sure the developers would have avoided it. And I also doubt that there will be released 2 different versions.

Probably the best solution on short term: change the hosting company. I know, this is not ideal either, but probably the easiest way.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.687 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form