Welcome, Guest
Username: Password:

TOPIC: Installation problem

Installation problem 6 years 3 months ago #37173

  • vguillemin
  • vguillemin's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Thank you received: 1
  • Karma: 0
Hello,

When i try to install limesurvey, i have an error message line 46.

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in
/home/www/web/limesurvey/config.php on line 46

$rootdir = "/home/www/web/limesurvey"; (this is the line 46)

Can you help me ?

NB : $rooturl = "www.mydomain.fr/limesurvey/";
My site is hosted by Infomaniak

Thank you

Vincent
The administrator has disabled public write access.

Installation problem 6 years 3 months ago #37256

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5914
  • Thank you received: 357
  • Karma: 258
Please post lines 40-50 from your config.php file. XXX out any passwords.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Installation problem 6 years 3 months ago #37274

  • vguillemin
  • vguillemin's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Thank you received: 1
  • Karma: 0
// a database with other applications. Suggested prefix is 'lime_'

// File Locations
$rooturl = "www.xxxxxxxxxxx.fr/limesurvey/"; // The root web url for your limesurvey installation (without a trailing slash).
// The double quotes (") are important.

$rootdir = dirname(__FILE__); // This is the physical disk location for your limesurvey installation. Normally you don't have to touch this
// setting. If you use IIS then you MUST enter the complete rootdir e.g. : $rootDir='C:\Inetpub\wwwroot\limesurvey'!
// Some IIS and OS/2 installations also require to use forward slashes
// instead of backslashes, e.g. $rootDir='C:/Inetpub/wwwroot/limesurvey'!


Thanks

Vincent
The administrator has disabled public write access.

Installation problem 6 years 3 months ago #37285

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5914
  • Thank you received: 357
  • Karma: 258
Try to set
$rooturl = "http://{$_SERVER['HTTP_HOST']}/limesurvey"; 

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Installation problem 6 years 2 months ago #38324

  • vguillemin
  • vguillemin's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Thank you received: 1
  • Karma: 0
Hello,

I have this error now :

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/www/d1d54824de551d7be73289838b14ca12/web/limesurvey/config.php on line 43

For information my domain has an SSL link.

Thank you

Vincent
The administrator has disabled public write access.
The following user(s) said Thank You: Venugopalreddy11

Installation problem 6 years 2 months ago #38326

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5914
  • Thank you received: 357
  • Karma: 258
There still seems to be a syntax problem.
Can you xxx out any passwords and upload the complete config file here? Rename it from .php to .txt.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Installation problem 6 years 2 months ago #38333

  • vguillemin
  • vguillemin's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Thank you received: 1
  • Karma: 0
Attached the config file.

File Attachment:

File Name: config-20100218.txt
File Size:4 KB
The administrator has disabled public write access.

Installation problem 6 years 2 months ago #38335

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5914
  • Thank you received: 357
  • Karma: 258
At least at the version you uploaded there is a " ' " missing.
wrong:
$databasepass = 'xxx; // Password of db user
$dbprefix = ''; // A global prefix that can be added to all LimeSurvey tables. Use this if you are sharing
The line must read
$databasepass = 'xxx;' // Password of db user

Please check your file for missing " ' " or ";" and the like.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Installation problem 6 years 2 months ago #38347

  • vguillemin
  • vguillemin's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Thank you received: 1
  • Karma: 0
I checked all the "'" and all the ";" and effictivly one "'" who was missing.
I have added the "'" who was missing but now i have this error :


Warning: require(dirname(__FILE__)/version.php) [function.require]: failed to open stream: No such file or directory in /home/www/d1d54824de551d7be73289838b14ca12/web/limesurvey/common.php on line 22

Warning: require(dirname(__FILE__)/version.php) [function.require]: failed to open stream: No such file or directory in /home/www/d1d54824de551d7be73289838b14ca12/web/limesurvey/common.php on line 22

Fatal error: require() [function.require]: Failed opening required 'dirname(__FILE__)/version.php' (include_path='.:/opt/php/lib/php') in /home/www/d1d54824de551d7be73289838b14ca12/web/limesurvey/common.php on line 22

Have you a solution

Thanks

Vincent
The administrator has disabled public write access.

Installation problem 6 years 2 months ago #38351

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5914
  • Thank you received: 357
  • Karma: 258
Looks like path problems.

Which URL do you use to call the admin login screen?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Installation problem 6 years 2 months ago #38397

  • vguillemin
  • vguillemin's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Thank you received: 1
  • Karma: 0
Hello,

I have finaly download the last version of limesurvey.
The installation was a success but now i have another problem.
When i try to connect with admin account, nothing happened !
I have no error message.
How is it possible ?

Thanks


Vince
The administrator has disabled public write access.

Installation problem 6 years 2 months ago #38443

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5914
  • Thank you received: 357
  • Karma: 258
1. Please switch on debug mode by adding the following line to your config.php file:
$debug = '1';

Are there any additional errors reported on top of the page?

2. Please check the installation FAQ: docs.limesurvey.org/tiki-index.php?page=...meSurvey#After_Login

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Installation problem 6 years 2 months ago #38511

  • vguillemin
  • vguillemin's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Thank you received: 1
  • Karma: 0
Hello,

I have read your instructions and i have put debug = '1' in the config.php.
I try to connect but no message appeared.
I have read your link faq installation and i think my problem is that the limesurvey database is encoded in utf8.
The problem is that AINSI/iso is not available on my database !
How else can I use encoding: AINSI, binary ,....?

Thanks

Vince
The administrator has disabled public write access.

Installation problem 6 years 2 months ago #38581

  • c_schmitz
  • c_schmitz's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 975
  • Thank you received: 133
  • Karma: 97
vguillemin wrote:
Hello,

I have read your link faq installation and i think my problem is that the limesurvey database is encoded in utf8.
The problem is that AINSI/iso is not available on my database !
How else can I use encoding: AINSI, binary ,....?

Thanks

Vince

Vince, the database is supposed to be in UTF-8, so that is not our problem.
Did you check your web server error logs?
Best regards

Carsten Schmitz
LimeSurvey project leader
The administrator has disabled public write access.

Installation problem 6 years 2 months ago #38582

  • vguillemin
  • vguillemin's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Thank you received: 1
  • Karma: 0
Hello,

I can't access the log because my site is hosted by infomaniak.
I just opened a ticket for this problem.
I do various tests but without success and I think actually that problem must be at the PHP server.

Thank you

Vince
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.217 seconds