Check out the LimeSurvey source code on GitHub!

error during install

  • jbelanger
  • jbelanger's Avatar Topic Author
  • Visitor
  • Visitor
7 years 5 months ago #29102 by jbelanger
I am trying to install the software and am running into a error when trying to run the install script.

Parse error: syntax error, unexpected T_STRING in /home/content/p/a/t/path123/html/limesurvey/admin/install/index.php on line 41

limesurvey185plus-build7394-20090803

Any help is appreciated.

Please Log in to join the conversation.

More
7 years 5 months ago #29125 by Mazi
1. Which PHP version?

2. Which DB version?

3. Please switch on debug mode by adding the following line to your config.php file:
$debug = '1';

Are there any errors reported?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

  • jbelanger
  • jbelanger's Avatar Topic Author
  • Visitor
  • Visitor
7 years 5 months ago #29135 by jbelanger
1). PHP5.2.8
3). MySQL - Database Version:5.0
3). runing debug mode did not indicated any errors, just the same as indicated before.

Thanks

Please Log in to join the conversation.

More
7 years 5 months ago #29136 by Mazi
Try to re-upload all the files in binary mode.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

  • jbelanger
  • jbelanger's Avatar Topic Author
  • Visitor
  • Visitor
7 years 5 months ago #29140 by jbelanger
Mazi,

Deleting the files and uploading in binary mode did the trick. Thanks for your help.

Please Log in to join the conversation.

More
7 years 5 months ago #29177 by Mazi
You're welcome! If our hints have been helpful and you enjoy limesurvey please consider a donation to the team . We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

  • HiPhil
  • HiPhil's Avatar
  • Visitor
  • Visitor
7 years 1 month ago - 7 years 1 month ago #34655 by HiPhil
Hi,

I have a similar problem to the OP, when I try to run the install script, I get the following error message:

Parse error: parse error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/www/web24/html/limesurvey/classes/adodb/adodb.inc.php on line 433

I am using
LimeSurvey Version 1.86 (more specifically: limesurvey186-build7697-20090930)
PHP Version 4.3.11
mySQL Version 5.0.45

I have turned on debug mode, it does not show any errors. And I have tried uploading everything in binary mode, this did also not have any effect. I've even tried using 2 different FTP clients to upload it, both binary.

Any help would be greatly appreciated.
Last Edit: 7 years 1 month ago by HiPhil.

Please Log in to join the conversation.

More
7 years 1 month ago #34682 by rakete
Generally, if you got such an error message within your PHP Skript:
[...]parse error, unexpected T[...]

it is always the same: The PHP-Interpreter can't parse your file because of a Syntax error...

2 Possibilitys:
* you corrupted the File by yourself while editing the file.
* The down- or upload corrupted your files

2 Solutions:
* Correct the Syntax errors
* upload your files again in binary mode.

Please Log in to join the conversation.

More
7 years 1 month ago #34701 by Mazi
HiPhil wrote:

I am using
LimeSurvey Version 1.86 (more specifically: limesurvey186-build7697-20090930)
PHP Version 4.3.11

As noted at the installation instructions Limesurvey 1.86 requires PHP 5, your PHP version is too old.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 1 week ago #54994 by lukasso
Hallo, I have same problem during the instalation. But I¨ve allready tryed uploading in binary mode, and both (MySql and Php) are in version higher then required. i've downloaded newest Limesurvey, 2.something beta.
the error message is " Parse error: syntax error, unexpected '<' in /3w/wz.cz/l/lukas-kaufman/dotaznik/FirePHPCore/fb.php on line 262 "

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form