Error 400 appears randomly when i upload a file

More
10 months 2 days ago - 10 months 2 days ago #185091 by Limuss
Hello Everyone:


Sometimes when i test a survey using a upload file answer, appears (not always) a

400 error "Bad Request" "The request could not be understood by the server due to malformed syntax. Please do not repeat the request without modifications."

I try to find, the cause of the problem, but when i see additional information in a developer console appears this error:

Microsoft Edge throws error: modaldialog.js (31,21) SCRIPT438: Object doesn't support property or method 'saveAndExit'

I put the code of a function openUpladModalDialog() modaldialog.js from here:
 
function openUploadModalDialog(){
    $('.upload').click(function(e) {
 
        e.preventDefault();
 
        var $this = $(this);
        var show_title   = getQueryVariable('show_title', this.href);
        var show_comment = getQueryVariable('show_comment', this.href);
        var pos          = getQueryVariable('pos', this.href);
        var fieldname    = getQueryVariable('fieldname', this.href);
        var buttonsOpts = {};
        buttonsOpts[uploadLang.returnTxt] = function() {
            $(this).dialog("close");
        };
 
        $('#file-upload-modal-' + fieldname).appendTo('body').modal();
        $(document).on('shown.bs.modal','#file-upload-modal-' + fieldname, function()
        {
            updateMaxHeightModalbody($(this));
        });
        $('#file-upload-modal-' + fieldname).on('hide.bs.modal', function() {
            var pass;
            var uploaderId = 'uploader' + fieldname;
            if(document.getElementById(uploaderId).contentDocument) {
                if(document.getElementById(uploaderId).contentDocument.defaultView)
                    {       /*Firefox*/
                    pass=document.getElementById(uploaderId).contentDocument.defaultView.saveAndExit(fieldname,show_title,show_comment,pos);
                }else{       /*IE8*/
                    pass=document.getElementById(uploaderId).contentWindow.saveAndExit(fieldname,show_title,show_comment,pos);
                }
            }else{    /*IE6*/
                pass=document.getElementById(uploaderId).contentWindow.saveAndExit(fieldname,show_title,show_comment,pos);
            }
            return pass;
        });
    });
}
 
 


I use Limesurvey version 3.17.3+190429


Any advice will be well accepted.

Thanks for advance,
Attachments:
Last edit: 10 months 2 days ago by Limuss. Reason: add information

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
10 months 1 day ago #185116 by DenisChenu

Limuss wrote: I use Limesurvey version 3.17.3+190429

Seems to be an issue : please report.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: Limuss

Please Log in or Create an account to join the conversation.

More
10 months 1 day ago - 10 months 1 day ago #185138 by Limuss
Last edit: 10 months 1 day ago by Limuss.
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!