Token does not allow to go further than the welcome page

More
1 month 3 weeks ago #183842 by avirgolino
Hi,

I have an ongoing survey and so far everything was ok. But now, I have a problem. I attributed a token for each participant and more than 70 persons, since March, already answered to the entire questionnaire, without any problem. Today, when the participants enter the token, they go to the welcome page, click on the consent check box instead of going to the questions' page, and stay in the same page with the check box no longer checked (image in attach).

I have the limesurvey version 3.17.0.

Can you please explain me if there is any problem going on?

Thank you.
All the best,
Attachments:

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
1 month 3 weeks ago #183853 by holch
Well, what did you change since you started? Any update to Limesurvey? Any update to the server?

It is hard to give you a diagnose based on the information provided.

It worked before, it doesn't work anymore. So there must have been some change. Usually systems like Limesurvey don't just change behaviour just out of fun. ;-)

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
1 month 3 weeks ago #183856 by DenisChenu

holch wrote: … just out of fun. …

But dev like fun \o/ :silly: :woohoo:

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
1 month 3 weeks ago #183863 by tpartner
Try disabling AJAX in the survey theme options.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com

Please Log in or Create an account to join the conversation.

More
1 month 3 weeks ago #183864 by avirgolino
I did not changed anything since I did not access Limesurvey in the last weeks. Only the interviewers, who only have access to the questionnaire link (don't have administration privileges), sent the link to the respondents. So, I don't have any other information to give.

Is this a case where the current version of the limesurvey was updated whithout my aware and had something to do with it?

Thanks

Please Log in or Create an account to join the conversation.

More
1 month 3 weeks ago #183867 by avirgolino
I realized now that the problem is not with the token or the privacy check box but with the next button. I removed the privacy message and text box but the problem persists and we cannot proceed after the welcome page...

Please Log in or Create an account to join the conversation.

More
1 month 3 weeks ago #183868 by tammo
Is it possible to place here a link to the survey. Possibly with a token that will give access multiple times? You can delete the token afterwards.

Did you use a standard theme or have you used a customized theme?

Tammo


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey theme
toolsforresearch.com/limesurvey-responsive-template
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

More
1 month 3 weeks ago #183869 by avirgolino
Thank you.

I have a customized theme, based on the fruity theme.

Here goes the link: researchsurvey.limequery.com/115882?lang=pt (token: tammo)

Do you need anything else?

Thank you

Please Log in or Create an account to join the conversation.

More
1 month 3 weeks ago #183870 by holch
So your survey is running on the limesurvey GmbH servers and you are paying for the hosting. So it is possible that there was an update without you noticing.

You have the right to use the support of limesurvey GmbH, just create a token under support above.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

More
1 month 3 weeks ago #183871 by tammo
I guess that Holch already used the token, it is best to set the token to be able to be used multiple times...

Tammo


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey theme
toolsforresearch.com/limesurvey-responsive-template
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

More
1 month 3 weeks ago #183872 by holch
Correct, I assumed that Tammo's instructions would be followed and the "answers left" would be set high, so that more people can test the link.

Result of my test: with the privacy message, when you tick it and click on next, the same page is loaded and you can not continue. I guess we would need an lss export to test if it is a problem with the installation, with the questionnaire or a bug in limesurvey.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
1 month 3 weeks ago #183873 by tammo
And maybe faster: try to execute the survey with a standard theme, because there is a chance that the error is hidden in the theme.

Tammo


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey theme
toolsforresearch.com/limesurvey-responsive-template
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

More
1 month 3 weeks ago #183874 by DenisChenu

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
1 month 3 weeks ago #183875 by avirgolino
Thank you very much for your support. I created a similar theme and the problem is solved. However, I am still thinking about how did this happen since no one have access to the questionnaire as an administrator except me and I haven't been accessing Limesurvey in the last few days...

Anyway, the problem is solved.
Thank you again.

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!