DB error during installation - Version 3.14.11+180926

More
1 month 2 weeks ago #181219 by arunicbe
I am getting this error when I complete the installation Step 4 - Creation of Administrator account.

It is a fresh installation. The database user has permissions. The database and tables are created.

Could not add administrator settings: CDbException: The table "{{users}}" for active record class "User" cannot be found in the database. in /var/www/html/forms/framework/db/ar/CActiveRecord.php:2390 Stack trace: #0 /var/www/html/forms/framework/db/ar/CActiveRecord.php(413): CActiveRecordMetaData->__construct(Object(User)) #1 /var/www/html/forms/framework/db/ar/CActiveRecord.php(682): CActiveRecord->getMetaData() #2 /var/www/html/forms/application/models/LSActiveRecord.php(29): CActiveRecord->hasAttribute('created') #3 /var/www/html/forms/framework/db/ar/CActiveRecord.php(398): LSActiveRecord->behaviors() #4 /var/www/html/forms/application/models/User.php(53): CActiveRecord::model('User') #5 /var/www/html/forms/application/controllers/InstallerController.php(592): User::model() #6 /var/www/html/forms/application/controllers/InstallerController.php(87): InstallerController->stepOptionalConfiguration() #7 /var/www/html/forms/framework/web/CWebApplication.php(282): InstallerController->run('optional') #8 /var/www/html/forms/framework/web/CWebApplication.php(141): CWebApplication->runController('installer/optio...') #9 /var/www/html/forms/framework/base/CApplication.php(185): CWebApplication->processRequest() #10 /var/www/html/forms/index.php(194): CApplication->run() #11 {main}.


The server details are:
] #php -v
PHP 7.1.26 (cli) (built: Jan 9 2019 08:02:33) ( NTS )
]# mysql -V
mysql Ver 15.1 Distrib 5.5.60-MariaDB, for Linux (x86_64) using readline 5.1
]# uname -r
3.10.0-862.14.4.el7.x86_64

]# cat /etc/*release|head -n1
CentOS Linux release 7.6.1810 (Core)


How to fix this error?

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
1 month 2 weeks ago #181237 by holch
I have no idea about the error, but if you are doing a new install, why would you use an outdated version of limesurvey in the first place (it is already over 5 months old)? Maybe there is an error in exactly this version and it has long been fixed in the subsequent releases (and there have been quite a few since September 2019)?

I would first download the most recent version of Limesurvey, which currently is 3.16.0+190225

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!