What can cause "Resume" function to not work?

More
8 months 2 weeks ago #178096 by achstil
Hi

Sometimes when testing the "Resume" functionality, the saved survey is empty, i.e. the user clicks the links sent by email - the survey opens but with no answers registered from last use.

This happens inconsistently - and maybe once every 8 or 9 tries.

The survey is not very big, but e.g. the first question is a multiple choice question with 100 checkmarks. When testing I tend to be very quick. So my hypothesis is that its a matter of setting cache:false in the header? Or maybe the page is not actually finished loading when I click "Resume" button? In that case a solution might be to hide the resume button with display none for a few seconds?

But I would very much like to know, if anybody has hints to what could be causing this situation.

sincerely

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
8 months 5 days ago #178505 by achstil
For the record we are using php 7.2 and postgresql 10.6

Is it possible that we should try another setup?

Please Log in or Create an account to join the conversation.

More
8 months 5 days ago - 8 months 5 days ago #178506 by tpartner
Try disabling AJAX in the survey theme options. This will cause only single pages to be loaded at a time instead of the whole survey.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com
Last edit: 8 months 5 days ago by tpartner.
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

More
8 months 5 days ago #178521 by achstil
That would also mean I'd loose some functionality? E.g. question 8 is only shown if question 6 == "Yes". This works now - but if I disable ajax, I have to create to survey groups ans present questions group by group?

Please Log in or Create an account to join the conversation.

More
8 months 5 days ago #178522 by tpartner
No, relevance should work with or without AJAX.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

More
8 months 5 days ago #178524 by achstil
Also on the same page? If AJAX setting is only meant for background data processesing and if it can create problems , shouldn't it be disabled by default?

I am trying to understand what the trade off for me will be, and what new issues might arise.

Will see what happens.

Please Log in or Create an account to join the conversation.

More
8 months 5 days ago #178525 by tpartner
As I understand it, the only issue may be slightly longer load times but I have not noticed the those.

I disable AJAX in all of my themes - I have seen too many issues with my clients and here in the forums to trust it.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!