localhost in invitation urls

More
5 months 1 week ago - 5 months 1 week ago #170623 by porschberg
porschberg created the topic: localhost in invitation urls
Hi,

I installed limesurvey via docker ( hub.docker.com/r/crramirez/limesurvey/ ).

I created a survey and generated some invitations. However the the invitation url looks like:

http://localhost/index.php/542122?token=4fxPDQGNgnpiV53&lang=de

I would like to change the url to something like

foo.example.org/index.php/542122?token=4fxPDQGNgnpiV53&lang=de

Where can I configure this?

I have version: Version 2.72.3+171020

Best regards
Thomas
Last Edit: 5 months 1 week ago by DenisChenu. Reason: Usage of example.org

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago - 5 months 1 week ago #170624 by porschberg
porschberg replied the topic: localhost in invitation urls
I think I found a solution:
I edited config-defaults.php , I changed

$config = ' mywish-name.example.org/ ';

And now it seems to work.

Is it a good solution or is there something better?
Last Edit: 5 months 1 week ago by DenisChenu. Reason: Usage of example.org

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #170637 by DenisChenu
DenisChenu replied the topic: localhost in invitation urls
manual.limesurvey.org/Optional_settings#Advanced_path_settings

publicurl: This should be set to the URL location of your 'public scripts'. The public scripts are those located in the "limesurvey" folder (or whatever name you gave to the directory that all the other scripts and directories are kept in). This settings is available in config.php and it is used when token emails are sent.


Never update config-default, its not done for this …

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago - 5 months 1 week ago #170641 by tpartner
tpartner replied the topic: localhost in invitation urls
What Denis means is that all config settings should be changed in config.php, not in config-defaults.php.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Last Edit: 5 months 1 week ago by tpartner.

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #170646 by DenisChenu
DenisChenu replied the topic: localhost in invitation urls
What i mean : there are a specific settings done for this :). Best is to use it.

(and clearlu : i'm unsure $config= string can not break something)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!