theme extentions losing settings and duplicates appearing

More
3 months 3 weeks ago #170305 by joeschwab
joeschwab created the topic: theme extentions losing settings and duplicates appearing
I am struggling with a pretty frustrating bug in the theme editor in limesurvey version 3.4.

I have been "extending" this versions' "fruity" theme and attempting to make changes. (I know that previous template versions no longer work in this version)

Initially this seems to work, but seemingly at random the new logo and formatting changes seem to disapear from the theme. Upon investigation, I return to the theme listing and notice duplicates of the same theme extention i had previously created. but none of them will hold the logo setting. when i try to edit any of these duplicates, I get an error that the theme is not compatible.

I had even tried upgrading to the latest version, but the problem persisted. In addition, this caused a mysterious issue where survey participants were receiving "token mismatch" errors on the initial attempt at taking the survey (every single time). Rolling back the upgrade seemed to resolve the second issue.

We have live surveys that are losing formatting changes. As you can imagine, this is beyond frustrating.

Is it possible that the version of the fruity theme I'm trying to "extend" is in fact incompatible?

Could there be some sort of permissions problem?

Please Log in or Create an account to join the conversation.

More
3 months 3 weeks ago #170309 by tpartner
tpartner replied the topic: theme extentions losing settings and duplicates appearing
If using the latest version, please file a bug report.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The following user(s) said Thank You: LouisGac

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!