We are sorry but your session has expired

More
10 months 1 day ago #169073 by mariush
Hi,

We are getting a lot of complaints from users that when they try to complete a survey, the get the following error: We are sorry but your session has expired

Some of the users said they are getting this issue even when submitting the survey immediately after opening it, so it is definitely not a session timeout issue.

I've found a couple of other threads about the same topic, but none of them has a definitive answer.

Below is my server's phpinfo. I don't have permission to modify ini.php

Any assistance would be appreciated.

Thank you.

 

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
More
10 months 1 day ago #169077 by mariush
Thank you for the reply.

I can't seem to find the Session lifetime (seconds): option in Global Settings. I am running LimeSurvey Version 3.7.2+180508

Is there another way to set the session lifetime?

Just to clarify, the users get an issue even when they immediately complete the survey (e.g. 3 seconds from opening the survey to submitting it).

Other users are able to take a few minutes to complete the survey without issues.

Please Log in or Create an account to join the conversation.

More
10 months 1 day ago #169078 by LouisGac
manual.limesurvey.org/Global_settings

"Session lifetime (seconds) (only available with database sessions): Defines the time in seconds after which a survey session expires (provided there is no action from the participant). When using regular, file-based sessions, it is up to the system administrator to define the right values for 'session.gc_maxlifetime', 'session.save_path', etc., in the PHP configuration. Not only the web server settings but also the other similar settings of other applications may overwrite the setting for file-based sessions when editing it locally via the application. The maximum value that can be introduced is 65000 (seconds). It is recommendable to use a reasonable value. Bear in mind that, when using database sessions, check whether the MySQL setting called max_allowed_packet is set to a large value because some surveys generate over 2 MB of session data"

Please Log in or Create an account to join the conversation.

More
10 months 1 day ago #169080 by mariush
That option is not available for me. I'm guessing I'm not using database sessions.

Will moving to database sessions make any difference?

Please Log in or Create an account to join the conversation.

More
8 months 4 days ago #171546 by mfreund
I'm getting similar reports from my users. Like mariush, I do not see a setting for session lifetime in Global Settings/General.

In addition, even though I have token-based response persistence active, they are reporting that when they reload the survey it does not bring up their prior responses and they need to begin again from the beginning.

Any help with this would be welcome!

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #178145 by ccoupeau
Hello,
Hello,

Since me last version update (3.15.4) I have the same problem.

Did you find a solution that helped you solve the problem?

Thank You.
Charles.

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!