"Add user" will show "Email to XXXXX failed"

More
9 months 2 weeks ago - 9 months 2 weeks ago #148896 by sherry721
sherry721 created the topic: "Add user" will show "Email to XXXXX failed"
I am currently trying to create a new user, but whenever I save the new users it only says that sending the email has failed.

Unfortunately there is no way to test the email settings in Limesurvey (send a test mail).

Is there a way I can find out what went wrong?

I saw other people's question to find out root cause, but it still failed.:(

Limesurvey Using Version 2.62.2+170203 on Ubuntu 16.04 server
Mail server using version Microsoft Exchange 2010

Below is my email settings at Global settings -> Email settings
Default site admin email: This email address is being protected from spambots. You need JavaScript enabled to view it.
Administrator name: sherry.lin
Email method: SMTP
SMTP host: tpmail.tpvaoc.com
SMTP username: sherry.lin
SMTP encryption: Off
SMTP debug mode: On
Email batch size: 50


I found weird situation.
If I used "Configuration"-->"Create/edit user groups"-->"Email user group", message sent successfully!
If I used "Configuration"-->"Manage survey administrators"-->"Add user", it will show "Email to XXXXX failed. And the top will show below error.

2017-02-15 06:19:14 CLIENT -> SERVER: QUIT 2017-02-15 06:19:14 SERVER -> CLIENT: 221 2.0.0 Service closing transmission channel




Limesurvey server didn't have below log after I occurred sent email failed.
/var/log/apache2/server-error.log
and
/var/log/apache2/mail.log

can anyone help? its urgent ;(

thank you!
best
Sherry
Attachments:
Last Edit: 9 months 2 weeks ago by sherry721.

Please Log in to join the conversation.

More
9 months 2 weeks ago - 9 months 2 weeks ago #148897 by sherry721
sherry721 replied the topic: "Add user" will show "Email to XXXXX failed"
After create LDAP user, it will show below error.

Attachments:
Last Edit: 9 months 2 weeks ago by sherry721.

Please Log in to join the conversation.

More
9 months 2 weeks ago #148915 by DenisChenu
DenisChenu replied the topic: "Add user" will show "Email to XXXXX failed"
Hi,

My point of view : we must be allowed to create user without email.

And think we MUST be allowed for LDAP plugin or AuthWebserver plugin because : no email was to be sent.

Maybe best : report the bug / feature request ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: sherry721

Please Log in to join the conversation.

More
9 months 2 weeks ago #148927 by jelo
jelo replied the topic: "Add user" will show "Email to XXXXX failed"

DenisChenu wrote: My point of view : we must be allowed to create user without email.

bugs.limesurvey.org/view.php?id=12145
The following user(s) said Thank You: sherry721

Please Log in to join the conversation.

More
9 months 2 weeks ago #148955 by sherry721
sherry721 replied the topic: "Add user" will show "Email to XXXXX failed"
Hi Denis,

I only enabled LDAP plugin and it works great, I don't enable AuthWebserver plugin.
Where the log that I can provide to you about this issue?

Thanks and best regards,
Sherry

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!