SMTP mail

More
3 years 1 month ago #134174 by tasos
SMTP mail was created by tasos
Hello,

I tried to setup SMTP as a mail method but I can't get it to work. I keep getting errors like the following, does anyone have a clue about what might be wrong? Because I am pretty sure that the settings are correct.

Email to (*******) failed. Error message: SMTP connect() failed. github.com/PHPMailer/PHPMailer/wiki/Troubleshooting <li>SMTP debug output:</li><pre>2016-04-06 13:03:41 SERVER -> CLIENT: 220 mail.cmtprooptiki.gr ESMTP ready. 2016-04-06 13:03:41 CLIENT -> SERVER: EHLO survey.hc-barometer.gr 2016-04-06 13:03:41 SERVER -> CLIENT: 250-mail.cmtprooptiki.gr Hello survey.hc-barometer.gr [95.154.220.163] 250-SIZE 52428800 250-8BITMIME 250-PIPELINING 250-STARTTLS 250 HELP 2016-04-06 13:03:41 CLIENT -> SERVER: STARTTLS 2016-04-06 13:03:41 SERVER -> CLIENT: 220 TLS go ahead 2016-04-06 13:03:41 CLIENT -> SERVER: EHLO survey.hc-barometer.gr 2016-04-06 13:03:42 SERVER -> CLIENT: 250-mail.cmtprooptiki.gr Hello survey.hc-barometer.gr [95.154.220.163] 250-SIZE 52428800 250-8BITMIME 250-PIPELINING 250 HELP 2016-04-06 13:03:42 SMTP Error: Could not authenticate. 2016-04-06 13:03:42 CLIENT -> SERVER: QUIT 2016-04-06 13:03:42 SERVER -> CLIENT: 221 mail.cmtprooptiki.gr closing connection 2016-04-06 13:03:42 SMTP connect() failed. github.com/PHPMailer/PHPMailer/wiki/Troubleshooting </pre>
Not all emails were sent:


Thank you

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
3 years 1 month ago #134176 by jelo
Replied by jelo on topic SMTP mail

tasos wrote: [13:03:42 SMTP Error: Could not authenticate.


The user/passwort combination seems to be wrong. You should make sure you know how the SMTP server authentification policy. Today it's mostly the username and passwort of a mailaccount which is registered with the provider of that SMTP server.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #134180 by tasos
Replied by tasos on topic SMTP mail
Thank you for your reply, but I'm sure the user/password is correct. Tried it a lot of times and also tried with different emails.

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #134181 by jelo
Replied by jelo on topic SMTP mail
What LS version build is currently used?
Your SMTP server at mail.cmtprooptiki.gr is denying Limesurvey the access.
Since Communigate is used in your company you might ensure that no additional protection is in place which prevent delivering emails from Limesurvey.
www.communigate.com/communigatepro/Protection.html#Relay
The SMTP logfiles might show what went wrong with the authentication.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #134195 by tasos
Replied by tasos on topic SMTP mail
Version 2.50+ Build 160317

hmm, I checked the smtp logs of the firewall and didn't find anything, but I didn't check the Communigate logs... :huh: I will check them first thing in the morning because I don't have access right now. Thank you!

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #134216 by tasos
Replied by tasos on topic SMTP mail
Hello again,

I checked the communigate pro logs and this is what I found:

09:43:20.001 3 DNR-020379(mail.cmtprooptiki.gr) A-request(38 bytes) time-out ([127.0.0.1]:53 tried)
09:43:20.001 3 SMTPI-039809(mail.cmtprooptiki.gr) failed to resolve HELO parameter: DNS transaction timeout. Real address is [***.***.*.***]
09:43:20.001 3 SMTPI-039809([***.***.*.***]) read failed. Error Code=connection closed by peer

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #134220 by jelo
Replied by jelo on topic SMTP mail
Why do you think this part of the log is related to your Limesurvey installation?
Is the timestamp of this snippet in the same timerange when letting Limesurvey send emails via SMTP ?
The logfiles of Limesurvey SMTP connection won't show issues in HELO name IP resolving.

You should ask the administrator of your company for help. There are currently no signs of issues around Limesurvey itself.
You might update LimeSurvey to the newest version to check again. But I haven't found any bug-reports around mails sending and SMTP authentication.

Ensure that you try the username (which is often the email-address) for SMTP authentication in lowercase!

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!