Setting "hide tip" to Yes does not work after update to 2.06+ build 151018

More
2 years 8 months ago #127940 by fvanderstarre
fvanderstarre created the topic: Setting "hide tip" to Yes does not work after update to 2.06+ build 15
I noticed after updating to 2.06+ build 151018, that advanced question setting "hide tip" = Y does not work (see issue # 10004 in the bug tracker).
A workaround may be to put:
div.emtip { display: none; }
at the bottom of template.css .
But then question tips will never be shown and you'll have to update all your templates.....

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago - 2 years 8 months ago #127950 by holch
holch replied the topic: Setting "hide tip" to Yes does not work after update to 2.06+ build 15
Just tried it (you should mention here that this only refers to multipe choice questions, as you did in the bug report).

But it just works fine. The tip is hidden.

Do you use a custom template? If so, have you tried with one of the templates that comes with limesurvey and which has not been modified?

Here question with "Hide tip" set to "yes":



And here the same question with "hide tip" set to "no"




The screenshots are made with Google Chrome, but I also tried with Firefox and not problem (multiple choice question).

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Attachments:
Last Edit: 2 years 8 months ago by holch.

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago #127953 by holch
holch replied the topic: Setting "hide tip" to Yes does not work after update to 2.06+ build 15
Had a look at your example questionnaire of the bug report and there the comment is still showing. Not sure if this falls under "tip" though. Let's see what the developers say.

But hiding the standard tip that is shown for the question works, even with your survey. The "problem" seems to be the maximum number of answers. And I can understand why this isn't hidden, because it is a vital information for this question. If you would hide this tip, people wouldn't know what is wrong when they mark more than the maximum number of questions.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago - 2 years 8 months ago #127955 by fvanderstarre
fvanderstarre replied the topic: Setting "hide tip" to Yes does not work after update to 2.06+ build 15
Hi Holch,

Please check attached sample survey with a numeric question and minimum and maximum values set. Using default template, I still get question tip displayed after setting Hide tip to Yes.... :(
Note: I am referring to the text message: "Your answer must be between 18 and 99"
Cheers, Frank
Attachments:
Last Edit: 2 years 8 months ago by fvanderstarre. Reason: Additional information

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago #127957 by fvanderstarre
fvanderstarre replied the topic: Setting "hide tip" to Yes does not work after update to 2.06+ build 15
Some time ago I picked up this tip in the forum to suppress question tip display:
span.questionhelp {
display:none; }
in template.css (I believe it came from Tony P.).
This does not seem to work any more, not in all cases anyway. Has something been changed in this version (2.06+ 151018) which may affect this behavior?
Frank

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago #128093 by DenisChenu
DenisChenu replied the topic: Setting "hide tip" to Yes does not work after update to 2.06+ build 15
Hi,

Same than the bug : remove the span : codeguide.co/#css-selectors

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!