EM mistake when update from 2.0 to 2.05

More
2 years 8 months ago #119121 by iscar
iscar created the topic: EM mistake when update from 2.0 to 2.05
i think i notice this problem, i test it again now and get the same result.
update from 2.0 to 2.05 150310
lots of my survey has EM like {if(q1>=18,'big','small')}.after update, you can find lots of error as below


it means all the surveys cannot work after update.
Attachments:

Please Log in to join the conversation.

More
2 years 8 months ago - 2 years 8 months ago #119128 by Ben_V
Ben_V replied the topic: EM mistake when update from 2.0 to 2.05
It seems that you have to put your hands into PhpMyAdmin using REPLACE or other command.
UPDATE table_name SET column_name = REPLACE (column_name, 'oldword', 'newword')

The most important & complicated is to know exactly which tables (e.g. lime_questions & lime_answers) and columns (e.g. question for lime_questions table) may contain those strings...


If too complicated or dangerous restore a complete backup, LS files+db ;)

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
Last Edit: 2 years 8 months ago by Ben_V.

Please Log in to join the conversation.

More
2 years 8 months ago #119131 by iscar
iscar replied the topic: EM mistake when update from 2.0 to 2.05
i don't understand why i should replace mysql.
everything is ok in 2.0.
something wrong in my update process??

Please Log in to join the conversation.

More
2 years 8 months ago #119133 by wikimoo
wikimoo replied the topic: EM mistake when update from 2.0 to 2.05
.

tank you

Please Log in to join the conversation.

More
2 years 8 months ago #119135 by DenisChenu
DenisChenu replied the topic: EM mistake when update from 2.0 to 2.05
I think it's a caching issue with the THML editor.

I can not reproduce with:
- No super admin
- XSS activated
- HTML editor
on last version.

github.com/LimeSurvey/LimeSurvey/pull/173
bugs.limesurvey.org/view.php?id=8818

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
2 years 8 months ago - 2 years 8 months ago #119142 by iscar
iscar replied the topic: EM mistake when update from 2.0 to 2.05
reproduce with:
-super admin(it's default setting,we know js is have to use)
-filter html for XSS yes
-html editor
1.creat a survey in 2.0,add EM {if(q1>=18,'big','small')}
2.update to 2.05 150310
3.run logic file
4.it's the same error when you creat new EM {if(q1>=18,'big','small')}

I think this bug is not fixed.just google it komlenic.com/246/encoding-entities-to-work-with-ckeditor-3/
Last Edit: 2 years 8 months ago by iscar.

Please Log in to join the conversation.

More
2 years 7 months ago #119144 by DenisChenu
DenisChenu replied the topic: EM mistake when update from 2.0 to 2.05

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!