Platzhalter-Objekte werden nicht angezeigt

More
3 years 3 months ago - 3 years 3 months ago #110106 by JosiBacchantes
JosiBacchantes created the topic: Platzhalter-Objekte werden nicht angezeigt
Liebe LS-Community,

wie ich bereits in www.limesurvey.com/en/forum/german-forum...bei-import-2-05-1-91 beschrieben hab, musste ich aus Datenschutzgründen leider den Server wechseln.

Hierfür habe ich Limesurvey ganz unproblematisch neu auf einem sicheren Server installiert.
Der Import meines Fragebogens hat auch sehr gut geklappt.

Leider scheinen jedoch die Platzhalter auf dem neuen Server nicht zu funktionieren. Wenn ich in einem Text bspw. "Hallo {TOKEN:FIRSTNAME}!" einsetze steht im Fragebogen nur "Hallo !". Gleiches bei Token-Attributen.
Wenn ich den gleichen Fragebogen (incl. gleicher Token-Datei) wieder auf meinen eigenen Server importiere, funktioniert alles einwandfrei. Es scheint also am Server oder einer LimeSurvey-Einstellung zu liegen, die mir unbekannt ist. Habt ihr eine Idee?

Der neue Server hat folgende Eigenschaften:
- PHP Version 5.3.10-1ubuntu3.11
- Server Software: Apache/2.2.22 (Ubuntu)
- MySQL 5.5.37
- LS Version: 2.05+ Build 140612
- Bei der Installation hat er sich über fehlendes LDAP beschwert. Ist das das Problem?

Über baldige Hilfe wäre ich ausgesprochen glücklich. Hinken im Zeitplan ziemlich hinterhet :(.

Danke und liebe Grüße
Josi
Last Edit: 3 years 3 months ago by JosiBacchantes.

Please Log in to join the conversation.

More
3 years 3 months ago #110169 by JosiBacchantes
JosiBacchantes replied the topic: Platzhalter-Objekte werden nicht angezeigt
Die Ausdrücke werden übrigens nicht rot angezeigt. Also es scheint kein Fehler auf.
Wenn ich andererseits die Bezüge in eine Relevanzgleichung einfüge (z.B. ((TOKEN:ATTRIBUTE_67 >= "1"))) wird die Frage gar nicht geöffnet, obwohl die Bedingung erfüllt ist. Als ob er gar nicht drauf zugreifen kann.

Meine bisherigen Lösungsversuche waren u.A.:
die Token-Datei in UTF-8 abzuspeichern und hochzuladen -> kein erfolg

alle Dateiberechtigungen testweise auf 777 setzen (vielleicht kann er irgendwo nicht drauf zugreifen) -> still ongoing

Infolgedessen werde ich mal Limesurvey 2.05+ Build 140302 aufspielen, weil das auf meinem eigenen Server auch läuft, vielleicht klappts dann ja.

Ansonsten bin ich verzweifelt und ratlos. Über jedweden Tip oder jede Idee würde ich mich ungemein freuen.

Vielen lieben DanK!

Please Log in to join the conversation.

More
3 years 3 months ago #110172 by c_schmitz
c_schmitz replied the topic: Platzhalter-Objekte werden nicht angezeigt
Dies was ein Bug und sollte in der aktuellsten Version behoben sein. Also einfach mal aktualisieren und gucken ob das Problem immer noch besteht.

Best regards

Carsten Schmitz
LimeSurvey project leader
The following user(s) said Thank You: JosiBacchantes

Please Log in to join the conversation.

More
3 years 3 months ago #110175 by JosiBacchantes
JosiBacchantes replied the topic: Platzhalter-Objekte werden nicht angezeigt
Ha, ich war der Überzeugung, ich hätte die neueste Version. Das hats gebracht.
Vielen vielen Dank!

phew. :).

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now