Check out the LimeSurvey source code on GitHub!

end_url parameter wrapped in span

More
3 years 6 months ago #98066 by laxwcrb73c
Hallo - meine Umfrage (Version 2.00+ Build 130611)
packt die end_url parameter in spans

some.server/limesurvey/end.php?user={INS...NSERTANS:184361X4X79 }

erscheint als ?user=<span id='LEMtailor_Q_0_7'>6666</span>&...

wie kann ich das besser machen?.

Herzliche Grüße,
Axel

Please Log in to join the conversation.

More
3 years 6 months ago #98080 by Mazi
Setze statt "INSERTANS" mal den Fragecode in Klammern in die URL, z. B: ?user={question22}


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 5 months ago #98297 by laxwcrb73c
Habe ich gemacht - bringt leider keine Änderung - wird auch in einen span tag eingepackt :(

Please Log in to join the conversation.

More
3 years 5 months ago #98309 by Mazi
Kannst du mal einen Beispielfragebogen anhängen?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 5 months ago #98343 by laxwcrb73c
hier mal ein testlink zum fragebogen und die lss
46.165.161.179/limesurvey/index.php/surv...X2X3/Axel%20Huizinga
Attachments:

Please Log in to join the conversation.

More
3 years 5 months ago #98346 by Mazi
Evtl. liegt das Problem bei dem Umfrageformat. Die <span> Elemente werden immer genutzt, wenn Limesurvey mittels JavaScript direkt auf der aktuellen Seite etwas updaten muss.

Wenn du die Umfrage im Frage-für-Frage Modus betreibst, sollte dies das Problem lösen.

Zur Not einfach in Gruppe-für-Gruppe wechseln und in eine einzelne Gruppe eine Frage mit "Vielen Dank für die Teilnahme" setzen, wenn du sonst den Rest auf einer Seite haben möchtest.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 5 months ago #98350 by laxwcrb73c
Beim Frage-für-Frage Modus hatte ich das Problem das der Querystring nicht weitergegeben wird und die vorgegebenen Felder nur auf der ersten Seite verfügbar waren.

Im Gruppe-für-Gruppe Modus ist der Querystring der End-Url korrekt - allerdings werden in diesem Modus auf der Willkommenseite die in der Url übergebenen Variablen nicht eingefügt...

Es sollte doch möglich sein die Nutzung der span Elemente generell zu konfigurieren.

Please Log in to join the conversation.

More
3 years 5 months ago #98352 by Mazi
In jedem Modus sollten die Werte korrekt per URL aufgenommen werden.

Welche Limesurvey-Version nutzt du?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 5 months ago #98361 by laxwcrb73c
Version 2.00+ Build 130611

Please Log in to join the conversation.

More
3 years 5 months ago #98364 by Mazi
Hmm, ich habe eine etwas aktuellere Version getestet.

Versuch es doch mal unter demo.limesurvey.org/admin (user: admin, PW: test). Da sollte immer die aktuellste Version laufen.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form