Einbinden von Bildern funtkioniert nicht.

More
4 years 1 month ago #93000 by Peridot
Liebes Forum!

ich habe Probleme, Bilder in die Umfrage einzubinden.

Nach dem Hochladen der Bilder unter "Bild-Eigenschaften" bekomme ich die Bilder korrekt angezeigt. Nach der Auswahl erscheint im Vorschaufenster jedoch nur ein rotes Quadrat mit einem X, und in der Umfrage wird entsprechend nur ein fehlerhafter Platzhalter angezeigt. Ich habe alle mir bekannten Möglichkeiten ausprobiert, den Fehler zu beseitigen, z.B.:

- Bildnamen überprüft
- Verschiedene Bildformate ausprobiert
- Rechte auf dem Server überprüft

...alles ohne Erfolg.

Über eine Idee, woran das Problem liegen könnte, würde ich mich sehr freuen.

Viele Grüße

Peridot

Please Log in to join the conversation.

More
4 years 1 month ago #93013 by holch
Mein erster Verdacht wären die Rechte. Kannst du denn auf die Bilder so zugreifen? Hast du versucht die Bilder mal per URL direkt anzusprechen? Hast du Zugang per FTP?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
4 years 1 month ago #93014 by holch
Welche Rechte haben denn die verschiedenen Ordner?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
4 years 1 month ago #93018 by Peridot
Hallo Holch!

Es lag wirklich an den Rechten.

Die Bilder wurden im Ordner "Images" unter meinem Survey abgelegt:

<img alt="" src="/umfrage/upload/surveys/781732/images/XXX.png" /></p>

Die Rechte waren wie folgt:

Owner permissions: Read, write, execute
Group permissions: Read
Public permissions: Read

Beim setzen der Rechte erfolgte das scheinbar nicht im vollständigen Tree, obwohl ich die Option ausgewählt hatte. Mich wundert nur, das ich nicht allen Ordnern unterhalb "upload" Leserechte einräumen kann (Erzeugt eine Fehlermeldung, auch direkt im FTP meiner Host-Administration.)

Ich habe soeben ein neues Verzeichnis auf einer anderen Ebene neu angelegt, und die Grafik von dort aus eingebunden. Funktioniert! :)

Vielen Dank für die Erinnerung, noch einmal alle Rechte des Trees einzeln zu überprüfen!

Peridot

Please Log in to join the conversation.

More
1 year 7 months ago #123642 by Donald01
Welche Rechte müssten denn die Ordner haben ?

Bei mir haben alle Ordner von " www.meinedomain.ch/limesurvey/upload/surveys/891172/images " die Rechte 755.
Das upgeloadete Bild namens "IMG_1732.jpg" selbst hat die Rechte 644.

Trotzdem kann das Bild nicht angezeigt werden.
Das Anzeigen eines Bildes braucht doch nur Leserechte, verstehe deshalb nicht warum das Bild nicht angezeigt wird.

Weiss jemand was ich falsch mache ?

Gruss Donald

Please Log in to join the conversation.

More
1 year 7 months ago #123677 by Mazi
Was passiert denn, wenn du die Rechte testweise auf "777" änderst?

Was zeigt er denn für einen Fehler an? 404 = Datei nicht gefunden oder was anderes wie "keine Rechte"?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
1 year 7 months ago - 1 year 7 months ago #123689 by Donald01
Geht auch nicht.
Ist ein Webserver User Problem.
Da die Ordner automatisch von Limesurvey generiert werden unter dem Webserver User, entstehen offenbar weitere Zugriffseinschränkungen die über die "normalen" Zugriffsrechte hinausgehen. Da müsste der Provider etwas am Webserver User ändern - aus Sicherheitsgründen werden die das wohl nicht tun.

Ich hab's jetzt via Workaround gelöst indem ich via FTP-Client extra für die Bilder einen Ordner erstelle und auch die Bilder via FTP hochlade - dann geht's.

Gruss Donald alias Alain aus dem IRC-Channel ;-)
Last Edit: 1 year 7 months ago by Donald01. Reason: -

Please Log in to join the conversation.